summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2023-02-13 00:45:24 +0000
committerJoão Figueiredo2023-02-13 00:45:24 +0000
commit9048dba3da3244995d48179d2b8cc70327c6875f (patch)
tree59071d1fafa349090d248c93b138281f8ee1f760
parent27195fdd35ec410c4f46ad1bf077ba92f5df6d8b (diff)
downloadaur-9048dba3da3244995d48179d2b8cc70327c6875f.tar.gz
Migrate to Qt6 (this time for real!)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f13d69171a88..199ef1c77a90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = kwindowsystem-git
pkgdesc = Access to the windowing system
- pkgver = 5.240.0_r761.gad91b0d
+ pkgver = 5.240.0_r763.gd3e2209
pkgrel = 1
url = https://community.kde.org/Frameworks
arch = x86_64
- groups = kf5-git
+ groups = kf6-git
license = LGPL
makedepends = git
makedepends = extra-cmake-modules-git
- makedepends = qt5-tools
+ makedepends = qt6-tools
makedepends = doxygen
- depends = qt5-x11extras
+ depends = qt6-x11extras
provides = kwindowsystem
conflicts = kwindowsystem
source = git+https://github.com/KDE/kwindowsystem.git
diff --git a/PKGBUILD b/PKGBUILD
index 3ff28b3580b2..64ac458de80a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,23 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=kwindowsystem-git
-pkgver=5.240.0_r761.gad91b0d
+pkgver=5.240.0_r763.gd3e2209
pkgrel=1
pkgdesc='Access to the windowing system'
arch=($CARCH)
url='https://community.kde.org/Frameworks'
license=(LGPL)
-depends=(qt5-x11extras)
-makedepends=(git extra-cmake-modules-git qt5-tools doxygen)
+depends=(qt6-x11extras)
+makedepends=(git extra-cmake-modules-git qt6-tools doxygen)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-groups=(kf5-git)
+groups=(kf6-git)
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- _ver="$(grep -m1 'set(KF5\?_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ _ver="$(grep -m1 'set(KF_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}