summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsabella Basso2022-04-01 15:09:49 -0300
committerIsabella Basso2022-04-01 15:09:49 -0300
commit0dbbdb5f3d4435da382b07397a917cbcc5f17f5b (patch)
treefde2c23d0e2c77069eaa780e6f186534569c921e
parent3181d8ccbcd4938618600ad4c615898224af993e (diff)
downloadaur-0dbbdb5f3d4435da382b07397a917cbcc5f17f5b.tar.gz
fixup PKGBUILD
This commit fixes: 1. Dependencies 2. Arch config And it also adds back tips to add kw to the PATH Signed-off-by: Isabella Basso <isabbasso@riseup.net>
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--kw.install6
3 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f37c57632524..6080f52a24a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,15 +3,19 @@ pkgbase = kworkflow-git
pkgver = 0.5.r88.gf984b81
pkgrel = 1
url = https://github.com/kworkflow/kworkflow
- arch = all
+ install = kw.install
+ arch = any
license = GPL2
depends = bc
+ depends = ccache
depends = qemu
depends = bash
depends = git
depends = tar
depends = libpulse
- depends = python-virtualenv
+ depends = sqlite3
+ depends = rsync
+ depends = pv
depends = bzip2
depends = lzip
depends = lzop
@@ -19,9 +23,7 @@ pkgbase = kworkflow-git
depends = xz
depends = perl-authen-sasl
depends = perl-io-socket-ssl
- depends = rsync
- depends = pv
- optdepends = pipewire-pulse: PipeWire backend
+ depends = python-virtualenv
optdepends = pulseaudio: PulseAudio backend
optdepends = dunst: Desktop notifications support
optdepends = graphviz: Pomodoro graphs support
diff --git a/PKGBUILD b/PKGBUILD
index 7a16e37f4700..682c1feac196 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,14 @@ pkgname="${_pkgname}-git"
pkgver=0.5.r88.gf984b81
pkgrel=1
pkgdesc='CLI tool for kernel development'
-arch=('all') # change to all
+arch=('any')
url='https://github.com/kworkflow/kworkflow'
source=("git+https://github.com/kworkflow/kworkflow")
license=('GPL2')
-depends=(bc qemu bash git tar libpulse python-virtualenv
+depends=(bc ccache qemu bash git tar libpulse sqlite3 rsync pv
bzip2 lzip lzop zstd xz
- perl-authen-sasl perl-io-socket-ssl rsync pv)
-optdepends=('pipewire-pulse: PipeWire backend'
- 'pulseaudio: PulseAudio backend'
+ perl-authen-sasl perl-io-socket-ssl python-virtualenv)
+optdepends=('pulseaudio: PulseAudio backend'
'dunst: Desktop notifications support'
'graphviz: Pomodoro graphs support'
'librsvg: Pomodoro graphs support'
@@ -25,6 +24,7 @@ optdepends=('pipewire-pulse: PipeWire backend'
provides=("${_lpkg}")
conflicts=("${_lpkg}")
sha256sums=('SKIP')
+install=kw.install
pkgver() {
cd "${srcdir}/${_pkgname}"
diff --git a/kw.install b/kw.install
new file mode 100644
index 000000000000..96f9bd6bff35
--- /dev/null
+++ b/kw.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo 'Append these to your shell profiles to enable autocomplete:'
+ echo ".bashrc or .zprofile: PATH=$HOME/.local/bin:\$PATH"
+ echo "config.fish: set -gx PATH $HOME/.local/bin PATH"
+ echo "then source the appropriate autocomplete file in: $HOME/.local/lib/kw/src"
+}