summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoe2018-06-04 11:17:28 +0200
committerzoe2018-06-04 11:17:28 +0200
commite9b01ae5daf6e7b444b0da159104f058a77a93f4 (patch)
tree2c14d3e1b2be1a4e9e4f25a06a324a5963b8a25c
parenteb59921ae4d1531429d46b5ceca91a58c158a8ae (diff)
downloadaur-e9b01ae5daf6e7b444b0da159104f058a77a93f4.tar.gz
add patch for qt5.11
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--kxstitch-qt5.11.patch48
3 files changed, 57 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9047ea74aac..1fed420051f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Apr 24 10:07:17 UTC 2018
+# Mon Jun 4 09:15:58 UTC 2018
pkgbase = kxstitch
pkgdesc = The program that lets you create cross stitch patterns and charts.
pkgver = 2.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://userbase.kde.org/KXStitch
install = kxstitch.install
arch = i686
@@ -20,8 +20,10 @@ pkgbase = kxstitch
conflicts = libmagick6
source = https://download.kde.org/stable/kxstitch/2.1.1/kxstitch-2.1.1.tar.xz
source = kxstitch.install
+ source = kxstitch-qt5.11.patch
sha1sums = 6f712bca3173b90149b67640fb1b63d02725c9ef
sha1sums = 8e58ce0776eff7ef29394a2f7a089191a4af0b1d
+ sha1sums = 8c392224f4fa0ce5e036bc59cbe42c407649c663
pkgname = kxstitch
diff --git a/PKGBUILD b/PKGBUILD
index 3baeed7d017d..5936d9da8e11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor : enckse <enckse [at] gmail [dot] com>
pkgname=kxstitch
pkgver=2.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="The program that lets you create cross stitch patterns and charts."
arch=('i686' 'x86_64')
depends=('plasma-workspace' 'imagemagick')
@@ -12,23 +12,18 @@ url="https://userbase.kde.org/KXStitch"
license=('GPL')
source=("https://download.kde.org/stable/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.xz"
"${pkgname}.install"
- #"imagemagick.patch::https://github.com/KDE/kxstitch/commit/295773f44bfda1227d85edf065a8de14dc889159.diff"
+ "kxstitch-qt5.11.patch"
)
sha1sums=('6f712bca3173b90149b67640fb1b63d02725c9ef'
'8e58ce0776eff7ef29394a2f7a089191a4af0b1d'
- #'e2d3c7ee0d9b62b7e0b1e4bcb327ee90f6edce3a'
+ '8c392224f4fa0ce5e036bc59cbe42c407649c663'
)
install=${pkgname}.install
build() {
cd "${srcdir}/kxstitch-${pkgver}"
- #sed -i 's/-DMAGICKCORE_HDRI_ENABLE=0/-DMAGICKCORE_HDRI_ENABLE=1/' CMakeLists.txt
-
- # Avoid bug in cmake :
- #sed -i '5i\cmake_policy(SET CMP0002 OLD)' CMakeLists.txt
-
- #cp ../imagemagick.patch .
- #patch -p1 < imagemagick.patch
+ cp ../kxstitch-qt5.11.patch .
+ patch -p1 < kxstitch-qt5.11.patch
rm -rf build
mkdir build
cd build
diff --git a/kxstitch-qt5.11.patch b/kxstitch-qt5.11.patch
new file mode 100644
index 000000000000..0e4c3f2b50ab
--- /dev/null
+++ b/kxstitch-qt5.11.patch
@@ -0,0 +1,48 @@
+diff --git a/src/LibraryPatternPropertiesDlg.cpp b/src/LibraryPatternPropertiesDlg.cpp
+index 8d2e24c..920ad25 100644
+--- a/src/LibraryPatternPropertiesDlg.cpp
++++ b/src/LibraryPatternPropertiesDlg.cpp
+@@ -15,6 +15,7 @@
+ #include <KHelpClient>
+ #include <KLocalizedString>
+ #include <KSharedConfig>
++#include <QIcon>
+
+
+ LibraryPatternPropertiesDlg::LibraryPatternPropertiesDlg(QWidget *parent, qint32 key, Qt::KeyboardModifiers modifiers, qint16 baseline, const QString &scheme, int width, int height, const QIcon &icon)
+diff --git a/src/LibraryPatternPropertiesDlg.h b/src/LibraryPatternPropertiesDlg.h
+index e23d76c..46e8779 100644
+--- a/src/LibraryPatternPropertiesDlg.h
++++ b/src/LibraryPatternPropertiesDlg.h
+@@ -20,6 +20,7 @@
+
+ class QHideEvent;
+ class QShowEvent;
++class QIcon;
+
+
+ class LibraryPatternPropertiesDlg : public QDialog
+diff --git a/src/TextElementDlg.cpp b/src/TextElementDlg.cpp
+index 4d88b1e..be364a2 100644
+--- a/src/TextElementDlg.cpp
++++ b/src/TextElementDlg.cpp
+@@ -19,6 +19,7 @@
+
+ #include <KHelpClient>
+ #include <KLocalizedString>
++#include <QButtonGroup>
+
+ #include "Element.h"
+
+diff --git a/src/TextElementDlg.h b/src/TextElementDlg.h
+index 6e43012..002edcd 100644
+--- a/src/TextElementDlg.h
++++ b/src/TextElementDlg.h
+@@ -21,6 +21,7 @@
+ class TextElement;
+ class QHideEvent;
+ class QShowEvent;
++class QButtonGroup;
+
+
+ class TextElementDlg : public QDialog