summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReberti Carvalho Soares2020-04-26 07:44:33 -0300
committerReberti Carvalho Soares2020-04-26 07:44:33 -0300
commit0d553d026a7013dcd09b5e7a6a684cf8ea01e83e (patch)
treee43c647a756ca9eb8b193eff0700edfa0eb1e7cb
downloadaur-0d553d026a7013dcd09b5e7a6a684cf8ea01e83e.tar.gz
First Commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2f7eb11d198
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = kyfm-git
+ pkgdesc = The fastest file manager.
+ pkgver = git
+ pkgrel = 0
+ epoch = 0
+ url = www.github.com/KisuYami/kyfm
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ makedepends = ncurses
+ makedepends = readline
+ depends = ncurses
+ depends = readline
+ source = git://github.com/KisuYami/kyfm
+ md5sums = SKIP
+
+pkgname = kyfm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db551bab72ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Reberti Carvalho Soares <6reberti6@gmail.com>
+pkgname=kyfm-git
+pkgver=git
+pkgrel=0
+epoch=0
+pkgdesc="The fastest file manager."
+arch=('i686' 'x86_64')
+url='www.github.com/KisuYami/kyfm'
+license=('GPLv2')
+depends=('ncurses' 'readline')
+makedepends=('ncurses' 'readline')
+options=()
+source=('git://github.com/KisuYami/kyfm')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname/"
+ make
+}
+
+package() {
+ cd "$pkgname/"
+
+ mkdir -p "$pkgdir"/usr/bin/
+ make DESTDIR="$pkgdir"/usr/bin/ install
+}
+
+# vim:set ts=2 sw=2 et: