summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortexhnolyze2022-01-19 21:08:56 +0100
committertexhnolyze2022-01-19 21:08:56 +0100
commit2febb21be56b7165a4f4932f04f87c0778a4534f (patch)
tree22d6ccbd5d702c415e58241f0382b9750b551c37
parent181fc76ef5824e955ed0777d45c9361704e022e0 (diff)
downloadaur-2febb21be56b7165a4f4932f04f87c0778a4534f.tar.gz
Update to 2.0.2
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c29952f0d2d4..322d3c90933d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = kyma-bin
- pkgdesc = Simple set of commands to manage a Kyma installation
- pkgver = 1.15.1
+ pkgdesc = Provides a set of commands you can use to install, manage, and test Kyma.
+ pkgver = 2.0.2
pkgrel = 1
url = https://github.com/kyma-project/cli
arch = x86_64
license = Apache
provides = kyma
provides = kyma-cli
- source = kyma-bin-1.15.1.tar.gz::https://github.com/kyma-project/cli/releases/download/1.15.1/kyma_Linux_x86_64.tar.gz
- sha256sums = 2c7bea87ea146cc611e4f66da74e1877d8bdc3f941c8067df5e80342a3aad195
+ source = kyma-bin-2.0.2.tar.gz::https://github.com/kyma-project/cli/releases/download/2.0.2/kyma_Linux_x86_64.tar.gz
+ sha256sums = 4c203bf0157d4283b254162d175d31601b949d4ea673f649e6b77f13e738eaec
pkgname = kyma-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 0e3c1fe87ffa..b9f732e2fcce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
-# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Maintainer: Joern Griepenburg <joegriepen at gmail dot com>
pkgname=kyma-bin
-pkgver=1.15.1
+pkgver=2.0.2
pkgrel=1
-pkgdesc='Simple set of commands to manage a Kyma installation'
+pkgdesc='Provides a set of commands you can use to install, manage, and test Kyma.'
arch=('x86_64')
url="https://github.com/kyma-project/cli"
license=('Apache')
provides=('kyma' 'kyma-cli')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/releases/download/${pkgver}/kyma_Linux_x86_64.tar.gz")
-sha256sums=('2c7bea87ea146cc611e4f66da74e1877d8bdc3f941c8067df5e80342a3aad195')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/releases/download/${pkgver}/kyma_Linux_${arch}.tar.gz")
+sha256sums=('4c203bf0157d4283b254162d175d31601b949d4ea673f649e6b77f13e738eaec')
package() {
install -Dm755 "${srcdir}"/kyma "${pkgdir}/usr/bin/kyma"
+
# Populate bash and zsh completions
- install -dm755 "${pkgdir}/usr/share/bash-completion/completions"
+ install -dm755 "${pkgdir}/usr/share/bash-completion/completions"
install -dm755 "${pkgdir}/usr/share/zsh/site-functions"
"${pkgdir}/usr/bin/kyma" completion bash > "${pkgdir}/usr/share/bash-completion/completions/kyma"
"${pkgdir}/usr/bin/kyma" completion zsh > "${pkgdir}/usr/share/zsh/site-functions/_kyma"
}
-# vim:set ts=2 sw=2 et: