summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortexhnolyze2022-05-06 05:15:37 +0200
committertexhnolyze2022-05-06 05:15:37 +0200
commit948bc9b7686cde34890df7468485a1c0be6e2571 (patch)
treeb0532b2aa1c4b540cac738ea683c59ea9e47261c
parenta5164b631ac4022169ed8f612a055234ad4769fc (diff)
downloadaur-948bc9b7686cde34890df7468485a1c0be6e2571.tar.gz
feat: update to version 2.2.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 322d3c90933d..d49d5ef922a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = kyma-bin
pkgdesc = Provides a set of commands you can use to install, manage, and test Kyma.
- pkgver = 2.0.2
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/kyma-project/cli
arch = x86_64
license = Apache
- provides = kyma
+ provides = kyma=2.2.0
provides = kyma-cli
- source = kyma-bin-2.0.2.tar.gz::https://github.com/kyma-project/cli/releases/download/2.0.2/kyma_Linux_x86_64.tar.gz
- sha256sums = 4c203bf0157d4283b254162d175d31601b949d4ea673f649e6b77f13e738eaec
+ conflicts = kyma
+ source = kyma-bin-2.2.0.tar.gz::https://github.com/kyma-project/cli/releases/download/2.2.0/kyma_Linux_x86_64.tar.gz
+ sha256sums = 1652b3a4c63cacb6536d628b56bdd08b7e0616c16e8febd2a27f449e73ef830b
pkgname = kyma-bin
diff --git a/PKGBUILD b/PKGBUILD
index b9f732e2fcce..9a50f05b0387 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
# Maintainer: Joern Griepenburg <joegriepen at gmail dot com>
+# Contributer: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=kyma-bin
-pkgver=2.0.2
+pkgver=2.2.0
pkgrel=1
-pkgdesc='Provides a set of commands you can use to install, manage, and test Kyma.'
-arch=('x86_64')
+pkgdesc="Provides a set of commands you can use to install, manage, and test Kyma."
url="https://github.com/kyma-project/cli"
+arch=('x86_64')
license=('Apache')
-provides=('kyma' 'kyma-cli')
+provides=("kyma=$pkgver" 'kyma-cli')
+conflicts=('kyma')
source=("${pkgname}-${pkgver}.tar.gz::${url}/releases/download/${pkgver}/kyma_Linux_${arch}.tar.gz")
-sha256sums=('4c203bf0157d4283b254162d175d31601b949d4ea673f649e6b77f13e738eaec')
+sha256sums=('1652b3a4c63cacb6536d628b56bdd08b7e0616c16e8febd2a27f449e73ef830b')
package() {
install -Dm755 "${srcdir}"/kyma "${pkgdir}/usr/bin/kyma"
@@ -20,3 +22,5 @@ package() {
"${pkgdir}/usr/bin/kyma" completion bash > "${pkgdir}/usr/share/bash-completion/completions/kyma"
"${pkgdir}/usr/bin/kyma" completion zsh > "${pkgdir}/usr/share/zsh/site-functions/_kyma"
}
+
+# vim:set ts=2 sw=2 et: