summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAttenuation2019-05-15 00:25:00 +0800
committerAttenuation2019-05-15 00:25:00 +0800
commitba53a4a9cd401377bb6c12177a23ded7d166c5f1 (patch)
tree07d5c5471a926d21d6391d7f98015959a5a4bd24
downloadaur-ba53a4a9cd401377bb6c12177a23ded7d166c5f1.tar.gz
first commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31492245c8ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = kytan
+ pkgdesc = High Performance Peer-to-Peer VPN by rust
+ pkgver = 0903be12
+ pkgrel = 1
+ url = https://github.com/changlan/kytan
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ source = kytan::git+https://github.com/changlan/kytan
+ sha256sums = SKIP
+
+pkgname = kytan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..856a06c7e1a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Attenuation <ouyangjun1999@gmail.com>
+pkgname=kytan
+pkgver=0903be12
+pkgrel=1
+pkgdesc='High Performance Peer-to-Peer VPN by rust'
+arch=('x86_64')
+url='https://github.com/changlan/kytan'
+license=('MIT')
+makedepends=('rust')
+depends=()
+source=("${pkgname}::git+${url}")
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 target/release/$pkgname "$pkgdir/usr/bin/$pkgname"
+} \ No newline at end of file