summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMangix2015-09-01 17:08:24 -0700
committerMangix2015-09-01 17:08:24 -0700
commitc6ce083f0513349728dc2712eb7b57747500c900 (patch)
treebe817b3e019c2af04554733573cc719703ea3727
downloadaur-c6ce083f0513349728dc2712eb7b57747500c900.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE6
-rw-r--r--PKGBUILD29
-rw-r--r--kzip.completion1
-rw-r--r--zipmix.completion1
5 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abbe4d7bd3f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kzipmix
+ pkgdesc = Ken Silverman's ZIP compressor
+ pkgver = 20150319
+ pkgrel = 1
+ url = http://www.jonof.id.au/kenutils
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = http://static.jonof.id.au/dl/kenutils/kzipmix-20150319-linux.tar.gz
+ source = kzip.completion
+ source = zipmix.completion
+ source = LICENSE
+ md5sums = 90568d3b6a901f6eedab9e9bd23f23d7
+ md5sums = 570e381fa45eead43054c287790cc07d
+ md5sums = 0b9327bd4b9186e09590b5bc478c9bab
+ md5sums = 6aca04829b82718d2cb26c9b45f9a570
+
+pkgname = kzipmix
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..3d893c565e61
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,6 @@
+PNGOUT / KZIP license
+http://www.advsys.net/ken/utils.htm#pngoutkziplicense
+
+The command line versions of PNGOUT.EXE and KZIP.EXE are free, as are the Mac and Linux ports. You may use PNGOUT- or KZIP-compressed content for non-commercial or commercial purposes.
+
+Redistributing, repackaging, or reusing the PNGOUT or KZIP executable is prohibited without the express consent of Ardfry Imaging, LLC, and a formal business agreement.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c0c78ee7be2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: DrZaius <lou[at]fakeoutdoorsman[dot]com>
+# Contributor: gueek <cyttam[at]gmail[dot]com>
+
+pkgname=kzipmix
+pkgver=20150319
+pkgrel=1
+pkgdesc="Ken Silverman's ZIP compressor"
+arch=('i686' 'x86_64')
+url="http://www.jonof.id.au/kenutils"
+license=('custom')
+source=(http://static.jonof.id.au/dl/kenutils/$pkgname-${pkgver}-linux.tar.gz
+ kzip.completion
+ zipmix.completion
+ LICENSE)
+md5sums=('90568d3b6a901f6eedab9e9bd23f23d7'
+ '570e381fa45eead43054c287790cc07d'
+ '0b9327bd4b9186e09590b5bc478c9bab'
+ '6aca04829b82718d2cb26c9b45f9a570')
+
+package() {
+ install -Dm755 ${srcdir}/${pkgname}-${pkgver}-linux/${CARCH}/kzip \
+ ${pkgdir}/usr/bin/kzip
+ install -Dm755 ${srcdir}/${pkgname}-${pkgver}-linux/${CARCH}/zipmix \
+ ${pkgdir}/usr/bin/zipmix
+ install -Dm644 ${srcdir}/kzip.completion ${pkgdir}/etc/bash_completion.d/kzip
+ install -Dm644 ${srcdir}/zipmix.completion ${pkgdir}/etc/bash_completion.d/zipmix
+ install -Dm644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/kzip.completion b/kzip.completion
new file mode 100644
index 000000000000..ef788d8f165e
--- /dev/null
+++ b/kzip.completion
@@ -0,0 +1 @@
+complete -f -X '!*.zip' kzip
diff --git a/zipmix.completion b/zipmix.completion
new file mode 100644
index 000000000000..57b7ab853267
--- /dev/null
+++ b/zipmix.completion
@@ -0,0 +1 @@
+complete -f -X '!*.zip' zipmix