summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMees Luten2020-09-23 17:54:08 +0200
committerMees Luten2020-09-23 17:54:08 +0200
commit0d72da397b08f239ea6b466a0b21b0d830285bca (patch)
treeaa243870884ee99513377a87c0bd08bbdfd4f1d3
downloadaur-0d72da397b08f239ea6b466a0b21b0d830285bca.tar.gz
Initial commit in new name format
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD46
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..579d15a015d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = l-band-decoders-git
+ pkgdesc = Small experimental project aimed at decoding various satellites such as Metop and FengYun
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/altillimity/L-Band-Decoders
+ arch = x86_64
+ license = GPLv3
+ makedepends = libfec-git
+ conflicts = satellite-decoders
+ source = l-band-decoders-git::git+https://github.com/altillimity/L-Band-Decoders.git
+ sha256sums = SKIP
+
+pkgname = l-band-decoders-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa2e48239d2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Mees Luten <mees [dot] luten [at] gmail [dot] com>
+pkgname=l-band-decoders-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="Small experimental project aimed at decoding various satellites such as Metop and FengYun"
+arch=('x86_64')
+url="https://github.com/altillimity/L-Band-Decoders"
+license=('GPLv3')
+depends=()
+makedepends=('libfec-git')
+provides=()
+conflicts=(satellite-decoders)
+replaces=()
+source=("$pkgname"::'git+https://github.com/altillimity/L-Band-Decoders.git')
+sha256sums=("SKIP")
+
+prepare() {
+ #rm -f -r $pkgname
+ #mv $pkgname-master $pkgname
+ mkdir -p "$pkgname"/build
+}
+
+build() {
+ cd "$pkgname"/build
+ cmake ../
+ make
+}
+
+package() {
+ cd "$pkgname"/build
+ install -Dm755 CCSDS\ Demuxer/CCSDS-Demux "${pkgdir}"/usr/bin/CCSDS-Demux
+ install -Dm755 FengYun\ Decoder/FengYun-Decoder "${pkgdir}"/usr/bin/FengYun-Decoder
+ install -Dm755 FengYun\ VIRR\ Decoder/FengYun-VIRR-Decoder "${pkgdir}"/usr/bin/FengYun-VIRR-Decoder
+ install -Dm755 METEOR\ BIS-M\ Decoder/METEOR-BIS-M-Decoder "${pkgdir}"/usr/bin/METEOR-BIS-M-Decoder
+ install -Dm755 METEOR\ Demodulator/METEOR-Demodulator "${pkgdir}"/usr/bin/METEOR-Demodulator
+ install -Dm755 METEOR\ Demuxer/METEOR-Demux "${pkgdir}"/usr/bin/METEOR-Demux
+ install -Dm755 METEOR\ MSU-MR\ Decoder/METEOR-MSU-MR-Decoder "${pkgdir}"/usr/bin/METEOR-MSU-MR-Decoder
+ install -Dm755 METEOR\ MTVZA\ Decoder/METEOR-MTVZA-Decoder "${pkgdir}"/usr/bin/METEOR-MTVZA-Decoder
+ install -Dm755 MetOp\ AVHRR\ Decoder/MetOp-AVHRR-Decoder "${pkgdir}"/usr/bin/MetOp-AVHRR-Decoder
+ install -Dm755 MetOp\ Decoder/MetOp-Decoder "${pkgdir}"/usr/bin/MetOp-Decoder
+ install -Dm755 NOAA\ Demodulator/NOAA-Demodulator "${pkgdir}"/usr/bin/NOAA-Demodulator
+ install -Dm755 NOAA\ MHS\ Decoder/MHS_Decoder "${pkgdir}"/usr/bin/MHS_Decoder
+ install -Dm755 QPSK\ Demodulator/QPSK-Demodulator "${pkgdir}"/usr/bin/QPSK-Demodulator
+ #install -Dm755 "${pkgdir}"/usr/bin/
+}
+