summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-09-12 19:03:19 +0200
committersL1pKn072021-09-12 19:03:37 +0200
commit9e811c4c04abd9639019f555f45924d88742b2b4 (patch)
tree7f3d509e86a3e55b01d2b1e5c586ff7b763381f7
parentb5f69a0b76738a36a21ee71953e93de89d4954c2 (diff)
downloadaur-9e811c4c04abd9639019f555f45924d88742b2b4.tar.gz
bump and add lib32
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD61
2 files changed, 60 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef3ba171cb0e..291f899419b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,26 @@
-# Generated by mksrcinfo v8
-# Fri Feb 8 19:44:38 UTC 2019
pkgbase = l-smash-git
- pkgdesc = MP4 muxer and other tools. (GIT Version)
- pkgver = v2.14.5.18.gf963b5a
+ pkgver = v2.14.5.21.g18a9ed2
pkgrel = 1
url = http://l-smash.github.io/l-smash
arch = x86_64
license = custom:l-smash
+ makedepends = glibc
makedepends = git
- depends = glibc
- provides = l-smash
provides = liblsmash.so
- conflicts = l-smash
source = git+https://github.com/l-smash/l-smash.git
sha256sums = SKIP
pkgname = l-smash-git
+ pkgdesc = MP4 muxer and other tools. (GIT Version)
+ depends = glibc
+ provides = liblsmash.so
+ provides = l-smash
+ provides = l-smash=v2.14.5.21.g18a9ed2
+ conflicts = l-smash
+pkgname = lib32-l-smash-git
+ pkgdesc = MP4 muxer and other tools. (GIT Version) (32-bits)
+ depends = l-smash=v2.14.5.21.g18a9ed2
+ provides = liblsmash.so
+ provides = lib32-l-smash
+ conflicts = lib32-l-smash
diff --git a/PKGBUILD b/PKGBUILD
index a10aa1910af8..f5fb80223c2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
-pkgname=l-smash-git
-pkgver=v2.14.5.18.gf963b5a
+pkgbase=l-smash-git
+pkgname=('l-smash-git'
+ 'lib32-l-smash-git'
+ )
+pkgver=v2.14.5.21.g18a9ed2
pkgrel=1
-pkgdesc="MP4 muxer and other tools. (GIT Version)"
arch=('x86_64')
url='http://l-smash.github.io/l-smash'
license=('custom:l-smash')
-depends=('glibc')
-makedepends=('git')
-provides=('l-smash'
- 'liblsmash.so'
- )
-conflicts=('l-smash')
+makedepends=('glibc'
+ 'git')
+provides=('liblsmash.so')
source=('git+https://github.com/l-smash/l-smash.git')
sha256sums=('SKIP')
@@ -22,21 +21,53 @@ pkgver() {
}
prepare() {
- mkdir -p build
+ mkdir -p build{32,64}
}
build() {
- cd build
+ cd "${srcdir}/build64"
../l-smash/configure \
--prefix=/usr \
--enable-shared \
- --disable-static
-
+ --disable-static \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}"
make
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH=/usr/lib32/pkgconfig
+
+ cd "${srcdir}/build32"
+ ../l-smash/configure \
+ --prefix=/usr \
+ --libdir='${exec_prefix}/lib32' \
+ --enable-shared \
+ --disable-static \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}"
+
+ make lib
+}
+
+package_l-smash-git() {
+ pkgdesc='MP4 muxer and other tools. (GIT Version)'
+ depends=('glibc')
+ provides+=('l-smash'
+ "l-smash=${pkgver}"
+ )
+ conflicts=('l-smash')
+ make -C build64 DESTDIR="${pkgdir}" install
+ install -Dm644 l-smash/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-package() {
- make -C build DESTDIR="${pkgdir}" install
+package_lib32-l-smash-git() {
+ pkgdesc='MP4 muxer and other tools. (GIT Version) (32-bits)'
+ depends=("l-smash=${pkgver}")
+ provides+=('lib32-l-smash')
+ conflicts=('lib32-l-smash')
+ make -C build32 DESTDIR="${pkgdir}" install-lib
+ rm -fr "${pkgdir}/usr/include"
install -Dm644 l-smash/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}