summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 17:09:06 +0200
committersl1pkn072015-06-08 17:09:06 +0200
commita375a2d85d7956b99d90d1709e5116edca2ccd2e (patch)
tree043b60d6ef7e438844222ca5edd66d47ef74001f
downloadaur-a375a2d85d7956b99d90d1709e5116edca2ccd2e.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4f3e0e4d05a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = l-smash-git
+ pkgdesc = MP4 muxer and other tools. (GIT Version)
+ pkgver = v2.3.0.146.geed0345
+ pkgrel = 1
+ url = http://l-smash.github.io/l-smash/
+ arch = i686
+ arch = x86_64
+ license = custom:l-smash
+ makedepends = git
+ depends = glibc
+ provides = lsmash
+ conflicts = lsmash
+ source = git+https://github.com/l-smash/l-smash.git
+ sha1sums = SKIP
+
+pkgname = l-smash-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d8bff84498a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=l-smash-git
+pkgver=v2.3.0.146.geed0345
+pkgrel=1
+url="http://l-smash.github.io/l-smash/"
+pkgdesc="MP4 muxer and other tools. (GIT Version)"
+arch=('i686' 'x86_64')
+license=('custom:l-smash')
+depends=('glibc')
+makedepends=('git')
+provides=('lsmash')
+conflicts=('lsmash')
+source=('git+https://github.com/l-smash/l-smash.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd l-smash
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd l-smash
+ ./configure --prefix=/usr --enable-shared --disable-static
+ make
+}
+
+package() {
+ cd l-smash
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}