summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-02-08 20:44:42 +0100
committersL1pKn072019-02-08 20:44:42 +0100
commitb5f69a0b76738a36a21ee71953e93de89d4954c2 (patch)
treededa9f795ae02493b81b9964484d4d767f56e768
parentf8c2247780dc7cd6f4b08391358d7df358c0fdd0 (diff)
downloadaur-b5f69a0b76738a36a21ee71953e93de89d4954c2.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e735a222418c..ef3ba171cb0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Apr 11 22:20:40 UTC 2018
+# Fri Feb 8 19:44:38 UTC 2019
pkgbase = l-smash-git
pkgdesc = MP4 muxer and other tools. (GIT Version)
- pkgver = v2.14.5.14.g04fbd81
+ pkgver = v2.14.5.18.gf963b5a
pkgrel = 1
url = http://l-smash.github.io/l-smash
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = l-smash-git
provides = liblsmash.so
conflicts = l-smash
source = git+https://github.com/l-smash/l-smash.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = l-smash-git
diff --git a/PKGBUILD b/PKGBUILD
index 167dc49be095..a10aa1910af8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=l-smash-git
-pkgver=v2.14.5.14.g04fbd81
+pkgver=v2.14.5.18.gf963b5a
pkgrel=1
pkgdesc="MP4 muxer and other tools. (GIT Version)"
arch=('x86_64')
@@ -9,28 +9,34 @@ url='http://l-smash.github.io/l-smash'
license=('custom:l-smash')
depends=('glibc')
makedepends=('git')
-provides=('l-smash' 'liblsmash.so')
+provides=('l-smash'
+ 'liblsmash.so'
+ )
conflicts=('l-smash')
source=('git+https://github.com/l-smash/l-smash.git')
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd l-smash
echo "$(git describe --long --tags | tr - .)"
}
+prepare() {
+ mkdir -p build
+}
+
build() {
- cd l-smash
- ./configure \
+ cd build
+ ../l-smash/configure \
--prefix=/usr \
--enable-shared \
--disable-static
+
make
}
package() {
- cd l-smash
- make DESTDIR="${pkgdir}" install
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ make -C build DESTDIR="${pkgdir}" install
+ install -Dm644 l-smash/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}