summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-09-12 19:06:40 +0200
committersL1pKn072021-09-12 19:06:40 +0200
commitc3ce4b2a745e8ff6ccc6b7f072183119fc6a4568 (patch)
treeda87a25477457d6d64f8e5d4dc3c80f749800187
parent9e811c4c04abd9639019f555f45924d88742b2b4 (diff)
downloadaur-c3ce4b2a745e8ff6ccc6b7f072183119fc6a4568.tar.gz
fix provides
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 291f899419b4..7e7a2e69f7f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,21 +6,20 @@ pkgbase = l-smash-git
license = custom:l-smash
makedepends = glibc
makedepends = git
- provides = liblsmash.so
source = git+https://github.com/l-smash/l-smash.git
sha256sums = SKIP
pkgname = l-smash-git
pkgdesc = MP4 muxer and other tools. (GIT Version)
depends = glibc
- provides = liblsmash.so
provides = l-smash
+ provides = liblsmash.so
provides = l-smash=v2.14.5.21.g18a9ed2
conflicts = l-smash
pkgname = lib32-l-smash-git
pkgdesc = MP4 muxer and other tools. (GIT Version) (32-bits)
depends = l-smash=v2.14.5.21.g18a9ed2
- provides = liblsmash.so
provides = lib32-l-smash
+ provides = liblsmash.so
conflicts = lib32-l-smash
diff --git a/PKGBUILD b/PKGBUILD
index f5fb80223c2c..8ec8a477f6cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,6 @@ url='http://l-smash.github.io/l-smash'
license=('custom:l-smash')
makedepends=('glibc'
'git')
-provides=('liblsmash.so')
source=('git+https://github.com/l-smash/l-smash.git')
sha256sums=('SKIP')
@@ -54,9 +53,10 @@ build() {
package_l-smash-git() {
pkgdesc='MP4 muxer and other tools. (GIT Version)'
depends=('glibc')
- provides+=('l-smash'
- "l-smash=${pkgver}"
- )
+ provides=('l-smash'
+ 'liblsmash.so'
+ "l-smash=${pkgver}"
+ )
conflicts=('l-smash')
make -C build64 DESTDIR="${pkgdir}" install
install -Dm644 l-smash/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
@@ -65,7 +65,9 @@ package_l-smash-git() {
package_lib32-l-smash-git() {
pkgdesc='MP4 muxer and other tools. (GIT Version) (32-bits)'
depends=("l-smash=${pkgver}")
- provides+=('lib32-l-smash')
+ provides=('lib32-l-smash'
+ 'liblsmash.so'
+ )
conflicts=('lib32-l-smash')
make -C build32 DESTDIR="${pkgdir}" install-lib
rm -fr "${pkgdir}/usr/include"