summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-01-23 16:41:58 +0100
committersL1pKn072023-01-23 16:41:58 +0100
commitf0a7071d6a0185b80cc992f8db75959b7c560fa9 (patch)
tree6cdec8ee7ad587a9ae5b9c7cf258d68e290eca8e
parentb8b5e94898c93e4b3ed3a192404240cafd6da5a1 (diff)
downloadaur-f0a7071d6a0185b80cc992f8db75959b7c560fa9.tar.gz
bump
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 24 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 158a06585b73..b965b02c21a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,28 @@
pkgbase = l-smash-git
- pkgver = 2.14.5.21.g18a9ed2
+ pkgver = 2.18.0.6.g9ce0ae2
pkgrel = 1
url = http://l-smash.github.io/l-smash
arch = x86_64
license = custom:l-smash
- makedepends = glibc
- makedepends = lib32-glibc
+ makedepends = obuparse-git
+ makedepends = lib32-obuparse-git
makedepends = git
options = debug
- source = git+https://github.com/l-smash/l-smash.git
+ source = git+https://github.com/vimeo/l-smash.git
sha256sums = SKIP
pkgname = l-smash-git
pkgdesc = MP4 muxer and other tools. (GIT Version)
- depends = glibc
+ depends = libobuparse.so
provides = l-smash
provides = liblsmash.so
- provides = l-smash=2.14.5.21.g18a9ed2
+ provides = l-smash=2.18.0.6.g9ce0ae2
conflicts = l-smash
pkgname = lib32-l-smash-git
pkgdesc = MP4 muxer and other tools. (GIT Version) (32-bits)
- depends = lib32-glibc
- depends = l-smash=2.14.5.21.g18a9ed2
+ depends = libobuparse.so
+ depends = l-smash=2.18.0.6.g9ce0ae2
provides = lib32-l-smash
provides = liblsmash.so
conflicts = lib32-l-smash
diff --git a/PKGBUILD b/PKGBUILD
index dcd4c7493e70..f10ca6fa354b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,16 @@ pkgbase=l-smash-git
pkgname=('l-smash-git'
'lib32-l-smash-git'
)
-pkgver=2.14.5.21.g18a9ed2
+pkgver=2.18.0.6.g9ce0ae2
pkgrel=1
arch=('x86_64')
url='http://l-smash.github.io/l-smash'
license=('custom:l-smash')
-makedepends=('glibc'
- 'lib32-glibc'
- 'git')
-source=('git+https://github.com/l-smash/l-smash.git')
+makedepends=('obuparse-git'
+ 'lib32-obuparse-git'
+ 'git'
+ )
+source=('git+https://github.com/vimeo/l-smash.git')
sha256sums=('SKIP')
options=('debug')
@@ -36,44 +37,46 @@ build() {
make
- export CC='gcc -m32'
- export CXX='g++ -m32'
export PKG_CONFIG_PATH=/usr/lib32/pkgconfig
cd "${srcdir}/build32"
../l-smash/configure \
--prefix=/usr \
--libdir='${exec_prefix}/lib32' \
- --cc="${CC}" \
--enable-shared \
--disable-static \
- --extra-cflags="${CFLAGS}" \
- --extra-ldflags="${LDFLAGS}"
+ --extra-cflags="-m32 ${CFLAGS}" \
+ --extra-ldflags="-m32 ${LDFLAGS}"
make lib
}
package_l-smash-git() {
pkgdesc='MP4 muxer and other tools. (GIT Version)'
- depends=('glibc')
+ depends=('libobuparse.so')
provides=('l-smash'
'liblsmash.so'
"l-smash=${pkgver}"
)
conflicts=('l-smash')
+
make -C build64 DESTDIR="${pkgdir}" install
+
install -Dm644 l-smash/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
package_lib32-l-smash-git() {
pkgdesc='MP4 muxer and other tools. (GIT Version) (32-bits)'
- depends=('lib32-glibc'
- "l-smash=${pkgver}")
+ depends=('libobuparse.so'
+ "l-smash=${pkgver}"
+ )
provides=('lib32-l-smash'
'liblsmash.so'
)
conflicts=('lib32-l-smash')
+
make -C build32 DESTDIR="${pkgdir}" install-lib
rm -fr "${pkgdir}/usr/include"
+
install -Dm644 l-smash/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}