summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-11-05 18:57:17 +0100
committersL1pKn072023-11-05 18:57:17 +0100
commitf1a85e831e029f76f62c0a5b53c2f9b1274417aa (patch)
tree6266e4483b2d4f25621f82af7cdffbbee38ec642
parentf0a7071d6a0185b80cc992f8db75959b7c560fa9 (diff)
downloadaur-f1a85e831e029f76f62c0a5b53c2f9b1274417aa.tar.gz
bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD45
2 files changed, 31 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b965b02c21a2..c3392e422655 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = l-smash-git
- pkgver = 2.18.0.6.g9ce0ae2
+ pkgver = 2.18.0.10.g2c0696c
pkgrel = 1
url = http://l-smash.github.io/l-smash
arch = x86_64
@@ -13,16 +13,18 @@ pkgbase = l-smash-git
pkgname = l-smash-git
pkgdesc = MP4 muxer and other tools. (GIT Version)
+ depends = obuparse-git
depends = libobuparse.so
provides = l-smash
provides = liblsmash.so
- provides = l-smash=2.18.0.6.g9ce0ae2
+ provides = l-smash=2.18.0.10.g2c0696c
conflicts = l-smash
pkgname = lib32-l-smash-git
pkgdesc = MP4 muxer and other tools. (GIT Version) (32-bits)
+ depends = lib32-obuparse-git
depends = libobuparse.so
- depends = l-smash=2.18.0.6.g9ce0ae2
+ depends = l-smash=2.18.0.10.g2c0696c
provides = lib32-l-smash
provides = liblsmash.so
conflicts = lib32-l-smash
diff --git a/PKGBUILD b/PKGBUILD
index f10ca6fa354b..35caba782953 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgbase=l-smash-git
-pkgname=('l-smash-git'
- 'lib32-l-smash-git'
- )
-pkgver=2.18.0.6.g9ce0ae2
+pkgname=(
+ 'l-smash-git'
+ 'lib32-l-smash-git'
+)
+pkgver=2.18.0.10.g2c0696c
pkgrel=1
arch=('x86_64')
url='http://l-smash.github.io/l-smash'
license=('custom:l-smash')
-makedepends=('obuparse-git'
- 'lib32-obuparse-git'
- 'git'
- )
+makedepends=(
+ 'obuparse-git'
+ 'lib32-obuparse-git'
+ 'git'
+)
source=('git+https://github.com/vimeo/l-smash.git')
sha256sums=('SKIP')
options=('debug')
@@ -53,11 +55,14 @@ build() {
package_l-smash-git() {
pkgdesc='MP4 muxer and other tools. (GIT Version)'
- depends=('libobuparse.so')
- provides=('l-smash'
- 'liblsmash.so'
- "l-smash=${pkgver}"
- )
+ depends=(
+ 'obuparse-git' 'libobuparse.so'
+ )
+ provides=(
+ 'l-smash'
+ 'liblsmash.so'
+ "l-smash=${pkgver}"
+ )
conflicts=('l-smash')
make -C build64 DESTDIR="${pkgdir}" install
@@ -67,12 +72,14 @@ package_l-smash-git() {
package_lib32-l-smash-git() {
pkgdesc='MP4 muxer and other tools. (GIT Version) (32-bits)'
- depends=('libobuparse.so'
- "l-smash=${pkgver}"
- )
- provides=('lib32-l-smash'
- 'liblsmash.so'
- )
+ depends=(
+ 'lib32-obuparse-git' 'libobuparse.so'
+ "l-smash=${pkgver}"
+ )
+ provides=(
+ 'lib32-l-smash'
+ 'liblsmash.so'
+ )
conflicts=('lib32-l-smash')
make -C build32 DESTDIR="${pkgdir}" install-lib