summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorb6b2020-03-22 16:18:43 -0700
committerb6b2020-03-22 16:18:43 -0700
commit6a44235b5be98a444e55dea11fdc49ce0c275e9f (patch)
tree53fab43c11c296115bbf9ede156e9f7fd4a0b42b
parenta15bbc1f6955195c69c54e26bb1a72b9b104f7e7 (diff)
downloadaur-l-smash-x264-tmod-git.tar.gz
Update to closer match official repository PKGBUILD
and update .SRCINFO too.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD45
2 files changed, 28 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4a681cafab5..841f210f8bd1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = l-smash-x264-tmod-git
pkgdesc = MP4 muxer and other tools (git version with support for compiling x264-tmod)
- pkgver = v2.14.5.20.gc98781c
+ pkgver = v2.14.5.21.g18a9ed2
pkgrel = 1
url = http://l-smash.github.io/l-smash
arch = x86_64
- license = custom:l-smash
+ license = custom
makedepends = git
depends = glibc
provides = l-smash
provides = liblsmash.so
conflicts = l-smash
- conflicts = l-smash-git
source = git+https://github.com/l-smash/l-smash.git
source = https://gist.githubusercontent.com/b6b/817262540eb2348c35b4c5592317d49f/raw/b4dcb1773713943187b58c2796aa7c3b379b9e8c/x264-tmod.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index bbaffd6a81d2..474041d18c08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,38 @@
# Maintainer: b6b <b6bb at pm dot me>
pkgname=l-smash-x264-tmod-git
-pkgver=v2.14.5.20.gc98781c
+pkgver=v2.14.5.21.g18a9ed2
pkgrel=1
pkgdesc='MP4 muxer and other tools (git version with support for compiling x264-tmod)'
-arch=('x86_64')
-url='http://l-smash.github.io/l-smash'
-license=('custom:l-smash')
-depends=('glibc')
-makedepends=('git')
+arch=(x86_64)
+url=http://l-smash.github.io/l-smash
+license=(custom)
+depends=(
+ glibc
+)
+makedepends=(
+ git
+)
provides=(
- 'l-smash'
- 'liblsmash.so'
+ l-smash
+ liblsmash.so
)
conflicts=(
- 'l-smash'
- 'l-smash-git'
+ l-smash
)
source=(
- 'git+https://github.com/l-smash/l-smash.git'
- 'https://gist.githubusercontent.com/b6b/817262540eb2348c35b4c5592317d49f/raw/b4dcb1773713943187b58c2796aa7c3b379b9e8c/x264-tmod.patch'
+ git+https://github.com/l-smash/l-smash.git
+ https://gist.githubusercontent.com/b6b/817262540eb2348c35b4c5592317d49f/raw/b4dcb1773713943187b58c2796aa7c3b379b9e8c/x264-tmod.patch
)
sha256sums=(
- 'SKIP'
- '2c0d80a45b0d2f7b2628b9bf32fef4261c39a3b46c91769f32771ca0fc2ce410'
+ SKIP
+ 2c0d80a45b0d2f7b2628b9bf32fef4261c39a3b46c91769f32771ca0fc2ce410
)
prepare() {
cd l-smash
- patch -i "$srcdir/x264-tmod.patch"
+ patch -i "${srcdir}"/x264-tmod.patch
}
pkgver() {
@@ -42,9 +45,11 @@ build() {
cd l-smash
./configure \
- --prefix='/usr' \
+ --prefix=/usr \
--enable-shared \
- --disable-static
+ --disable-static \
+ --extra-cflags="$CFLAGS" \
+ --extra-ldflags="$LDFLAGS"
make
}
@@ -52,6 +57,8 @@ build() {
package() {
cd l-smash
- make DESTDIR="$pkgdir" install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ make DESTDIR="${pkgdir}" install
+
+ install -dm 755 "${pkgdir}"/usr/share/licenses/l-smash
+ install -m 644 LICENSE "${pkgdir}"/usr/share/licenses/l-smash/
}