summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornow-im2017-09-05 17:02:53 +0600
committernow-im2017-09-05 17:02:53 +0600
commit340e277b0bf0f78ff0a2adc6fce7bc28b5b1c733 (patch)
treef0fef1fff5427116e967eb2015b7e71df12df22a
downloadaur-340e277b0bf0f78ff0a2adc6fce7bc28b5b1c733.tar.gz
Initial Commit with version 0.5 update
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47842b87c383
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = la-capitaine-icon-theme
+ pkgdesc = An icon pack designed to integrate with most desktop environments
+ pkgver = v0.5.0
+ pkgrel = 1
+ url = https://github.com/keeferrourke/la-capitaine-icon-theme
+ arch = any
+ license = GPL3
+ optdepends = elementary-icon-theme
+ optdepends = breeze-icons
+ optdepends = gnome-icon-theme
+ conflicts = la-capitaine-icon-theme-git
+ source = https://github.com/keeferrourke/la-capitaine-icon-theme/archive/v0.5.0.tar.gz
+ sha256sums = 5a4a1250ff770b2111db199b5b1cf1ec455572dde84fa34e953b46b50e17775b
+
+pkgname = la-capitaine-icon-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3195d7b6b5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: now-im <now.im.627@gmail.com>
+
+pkgname=('la-capitaine-icon-theme')
+pkgver=v0.5.0
+pkgrel=1
+pkgdesc="An icon pack designed to integrate with most desktop environments"
+arch=('any')
+url="https://github.com/keeferrourke/$pkgname"
+license=('GPL3')
+optdepends=('elementary-icon-theme' 'breeze-icons' 'gnome-icon-theme')
+conflicts=('la-capitaine-icon-theme-git')
+source=("https://github.com/keeferrourke/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('5a4a1250ff770b2111db199b5b1cf1ec455572dde84fa34e953b46b50e17775b')
+
+prepare() {
+ cd $pkgname-0.5.0
+
+}
+
+package() {
+ install -dm 755 "${pkgdir}"/usr/share/icons
+ cp -dr --no-preserve='ownership' $pkgname-0.5.0 "${pkgdir}"/usr/share/icons/$pkgname-0.5.0
+
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+ find "${pkgdir}" -type f -exec chmod 644 {} +
+}
+
+# vim: ts=2 sw=2 et: