summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-05-25 17:48:11 +0300
committerCaleb Maclennan2020-05-25 17:48:11 +0300
commit5e92318c56a9b83f94aa51a5b8b46d5ff31b4cf9 (patch)
treecdf19e793073f08066c994dfe2472706038b2e6e
parentb14ef009cc22c51115413b62623d29a198045017 (diff)
downloadaur-5e92318c56a9b83f94aa51a5b8b46d5ff31b4cf9.tar.gz
upgpkg: lab 0.17.2-4
Use isolated GO module path
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0f104b8d5d2..c8ad3bcd1335 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,11 +17,13 @@ sha256sums=('467cb35793c4129e7da68e4c63ef5ee96e9ca43f933c88758e90850f0d6c77b9')
prepare() {
cd "$pkgname-$pkgver"
+ export GOPATH="$srcdir"
go mod download
}
build () {
cd "$pkgname-$pkgver"
+ export GOPATH="$srcdir"
go build \
-trimpath \
-buildmode=pie \