summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Asuncion2017-11-14 16:01:14 -0800
committerJeremy Asuncion2017-11-14 16:01:14 -0800
commitf271db2450acaa509dff5b8158366c57e87948b6 (patch)
tree54303c91b8854ac1eaa119bd9271813b2e1104e1
downloadaur-f271db2450acaa509dff5b8158366c57e87948b6.tar.gz
:tada: Initial commit for lab aur package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69efd29b2f1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lab
+ pkgdesc = A hub-like tool for GitLab.
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://github.com/zaquestion/lab
+ arch = x86_64
+ license = custom:Unlicense
+ depends = git
+ optdepends = hub
+ source = https://github.com/zaquestion/lab/releases/download/v0.5.2/lab_0.5.2_linux_amd64.tar.gz
+ sha512sums = 35161114e7890bed191b053fc7daebcb0d5e6f574c636dcd23a1c4a2bc62b86c93fca7dd449f7fecc69536628b10810b630c02364f8238bca1074bf14a2b7192
+
+pkgname = lab
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9c2bd7c9b82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Jeremy Asuncion <jeremyasuncion808@gmail.com>
+
+pkgname='lab'
+pkgver='0.5.2'
+pkgrel=1
+pkgdesc="A hub-like tool for GitLab."
+arch=('x86_64')
+url="https://github.com/zaquestion/lab"
+license=('custom:Unlicense')
+depends=('git')
+optdepends=('hub')
+source=("https://github.com/zaquestion/lab/releases/download/v${pkgver}/lab_${pkgver}_linux_amd64.tar.gz")
+sha512sums=('35161114e7890bed191b053fc7daebcb0d5e6f574c636dcd23a1c4a2bc62b86c93fca7dd449f7fecc69536628b10810b630c02364f8238bca1074bf14a2b7192')
+
+package() {
+ cd $srcdir
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 lab $pkgdir/usr/bin/lab
+}