summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-05-25 16:25:10 +0300
committerCaleb Maclennan2020-05-25 16:25:10 +0300
commit2c7a39531931db216ded1fef6d10baa3e4543380 (patch)
tree5d3e3d6c5fb6e1fce3c520a876401d8bebe0806c
parentac64664d90dce4f9b3aa58c5b7a964b361e0ee77 (diff)
downloadaur-2c7a39531931db216ded1fef6d10baa3e4543380.tar.gz
upgpkg: lab-bin 0.17.2-3
Normalize with other lab packages
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81d0a1bab23c..5c73f0c68100 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = lab-bin
pkgdesc = A hub-like tool for GitLab (pre-built binary release)
pkgver = 0.17.2
- pkgrel = 2
- url = https://zaquestion.github.io/lab/
+ pkgrel = 3
+ url = https://zaquestion.github.io/lab
arch = x86_64
license = custom:Unlicense
- makedepends = go
depends = git
optdepends = hub
- conflicts = lab-git
+ provides = lab
conflicts = lab
source = https://github.com/zaquestion/lab/releases/download/v0.17.2/lab_0.17.2_linux_amd64.tar.gz
- sha512sums = d7d91e03f1030a740d440abaa0dc48eb54029807b921dad6b497c2641f54b295f916892a623286f39f53468a2477c327f51794b82dd55c763b62fd62b1bd0db9
+ sha256sums = abba37f6808daba347650b44249ef4793c849cc90a6b020a51e71dcfa3d34b99
pkgname = lab-bin
diff --git a/PKGBUILD b/PKGBUILD
index ececf9ce157e..404546e490fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,20 @@
# Contributor: Jeremy Asuncion <jeremyasuncion808@gmail.com>
# Contributor: Simon Legner <Simon.Legner@gmail.com>
-pkgname=lab-bin
+_pkgname=lab
+pkgname=$_pkgname-bin
pkgver=0.17.2
-pkgrel=2
-pkgdesc="A hub-like tool for GitLab (pre-built binary release)"
+pkgrel=3
+pkgdesc='A hub-like tool for GitLab (pre-built binary release)'
arch=('x86_64')
-url="https://zaquestion.github.io/lab/"
+url="https://zaquestion.github.io/$_pkgname"
license=('custom:Unlicense')
depends=('git')
optdepends=('hub')
-makedepends=('go')
-conflicts=("${pkgname%-bin}-git" "${pkgname%-bin}")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
source=("https://github.com/zaquestion/${pkgname%-bin}/releases/download/v$pkgver/lab_${pkgver}_linux_amd64.tar.gz")
-sha512sums=('d7d91e03f1030a740d440abaa0dc48eb54029807b921dad6b497c2641f54b295f916892a623286f39f53468a2477c327f51794b82dd55c763b62fd62b1bd0db9')
+sha256sums=('d7d91e03f1030a740d440abaa0dc48eb54029807b921dad6b497c2641f54b295f916892a623286f39f53468a2477c327f51794b82dd55c763b62fd62b1bd0db9')
build () {
./lab completion bash > completion.bash
@@ -22,8 +23,8 @@ build () {
}
package() {
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-bin}"/LICENSE
- install -Dm755 lab "$pkgdir"/usr/bin/lab
+ install -Dm755 -t "$pkgdir/usr/bin/" $_pkgname
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
install -Dm644 completion.bash "$pkgdir/usr/share/bash-completion/completions/lab"
install -Dm644 completion.zsh "$pkgdir/usr/share/zsh/site-functions/_lab"
}