diff options
author | Simon Legner | 2019-12-31 17:18:09 +0100 |
---|---|---|
committer | Simon Legner | 2019-12-31 17:18:09 +0100 |
commit | e97cda9b95909e650a597a270ff24c72d5ea6ffc (patch) | |
tree | 4029dce3b0bc07f04ec0882cef175e99af703d5d | |
parent | ea0de73eaa7226ddefd918ecc47b75ad62bc59da (diff) | |
download | aur-e97cda9b95909e650a597a270ff24c72d5ea6ffc.tar.gz |
upgpkg: lab-git 0.17.2.r1.gbe53a79-1
Add bash and zsh completion.
-rw-r--r-- | .SRCINFO | 2 | ||||
-rw-r--r-- | PKGBUILD | 6 |
2 files changed, 6 insertions, 2 deletions
@@ -1,6 +1,6 @@ pkgbase = lab-git pkgdesc = A hub-like tool for GitLab (git master branch) - pkgver = 0.17.0.r1.g550caf6 + pkgver = 0.17.2.r1.gbe53a79 pkgrel = 1 url = https://zaquestion.github.io/lab/ arch = x86_64 @@ -5,7 +5,7 @@ _pkgname=lab pkgname=$_pkgname-git -pkgver=0.17.0.r1.g550caf6 +pkgver=0.17.2.r1.gbe53a79 _branch=master pkgrel=1 pkgdesc="A hub-like tool for GitLab (git $_branch branch)" @@ -35,10 +35,14 @@ build () { -gcflags "all=-trimpath=$PWD" \ -asmflags "all=-trimpath=$PWD" \ -ldflags "-extldflags $LDFLAGS -X main.version=$pkgver" + ./lab completion bash > completion.bash + ./lab completion zsh > completion.zsh } package() { cd "$_pkgname" install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname"/LICENSE install -Dm755 lab "$pkgdir"/usr/bin/lab + install -Dm644 completion.bash "$pkgdir/usr/share/bash-completion/completions/lab" + install -Dm644 completion.zsh "$pkgdir/usr/share/zsh/site-functions/_lab" } |