diff options
author | João Figueiredo | 2021-02-01 23:36:07 +0000 |
---|---|---|
committer | João Figueiredo | 2021-02-01 23:36:07 +0000 |
commit | a67b8114757c11fc6d8581957bcee1e19bbb96a4 (patch) | |
tree | 37bad1055bcbc8fa2ce27207e1dd79e2a365e16f | |
parent | 397d709b0ea95aa0b66e12b628177e4946b3043b (diff) | |
download | aur-a67b8114757c11fc6d8581957bcee1e19bbb96a4.tar.gz |
Merged with official ABS labplot PKGBUILD
-rw-r--r-- | .SRCINFO | 13 | ||||
-rw-r--r-- | PKGBUILD | 35 |
2 files changed, 23 insertions, 25 deletions
@@ -1,21 +1,22 @@ pkgbase = labplot-git - pkgdesc = KDE Application for interactive graphing and analysis of scientific data, build from git - pkgver = 2.7.0.r805.g2b12b7900 + pkgdesc = KDE Application for interactive graphing and analysis of scientific data + pkgver = 2.9.0_r7979.gc4a151148 pkgrel = 1 url = https://labplot.kde.org/ arch = x86_64 license = GPL2 - makedepends = extra-cmake-modules - makedepends = kdelibs4support - makedepends = kdesignerplugin - makedepends = kdoctools makedepends = git + makedepends = extra-cmake-modules-git + makedepends = kdoctools-git + depends = cantor depends = netcdf depends = cfitsio depends = fftw depends = gsl depends = qt5-serialport depends = libcerf + depends = qt5-mqtt + depends = kuserfeedback-git provides = labplot conflicts = labplot source = git+https://github.com/KDE/labplot.git @@ -1,36 +1,33 @@ -# Maintainer: João Figueiredo <jf dot mundox at gmail dot com> +# Merged with official ABS labplot PKGBUILD by João, 2021/01/31 (all respective contributors apply herein) +# Maintainer: João Figueiredo <jf.mundox@gmail.com> # Contributor: Antonio Rojas <arojas@archlinux.org> # Contributor: Stefan Husmann <stefan-husmann@t-online.de> pkgname=labplot-git -pkgver=2.7.0.r805.g2b12b7900 +pkgver=2.9.0_r7979.gc4a151148 pkgrel=1 -arch=('x86_64') -pkgdesc="KDE Application for interactive graphing and analysis of scientific data, build from git" +arch=($CARCH) +pkgdesc="KDE Application for interactive graphing and analysis of scientific data" url="https://labplot.kde.org/" -license=('GPL2') -depends=('netcdf' 'cfitsio' 'fftw' 'gsl' 'qt5-serialport' 'libcerf') -makedepends=('extra-cmake-modules' 'kdelibs4support' 'kdesignerplugin' 'kdoctools' 'git') -conflicts=("${pkgname%-git}") -provides=("${pkgname%-git}") -source=('git+https://github.com/KDE/labplot.git') +license=(GPL2) +depends=(cantor netcdf cfitsio fftw gsl qt5-serialport libcerf qt5-mqtt kuserfeedback-git) +makedepends=(git extra-cmake-modules-git kdoctools-git) +conflicts=(${pkgname%-git}) +provides=(${pkgname%-git}) +source=("git+https://github.com/KDE/${pkgname%-git}.git") sha256sums=('SKIP') pkgver() { cd ${pkgname%-git} - git describe --always | sed 's+-+.r+' | tr - . + _ver="$(grep -m1 'add_definitions (-DLVERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)" + echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)" } build() { - [[ -d build ]] || mkdir build - cd build - cmake ../${pkgname%-git} \ - -DCMAKE_INSTALL_PREFIX=/usr \ - -DENABLE-CANTOR=OFF - make + cmake -B build -S ${pkgname%-git} + cmake --build build } package(){ - cd build - make DESTDIR="$pkgdir" install + DESTDIR="$pkgdir" cmake --install build } |