summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorb00rt00s2015-10-31 22:28:31 +0100
committerb00rt00s2015-10-31 22:28:31 +0100
commit9eaa8bf2157bb9a26cdf0bfb45c424d10ca5b0e9 (patch)
treeb19082b25a2401432a250b9cf2aa2c94c5e78e12
downloadaur-9eaa8bf2157bb9a26cdf0bfb45c424d10ca5b0e9.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4198a205753e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = labplot-kf5
+ pkgdesc = A free software data analysis and visualization application
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = http://labplot.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ depends = gsl
+ source = http://ftp.pbone.net/pub/kde/stable/labplot/2.1.0/src/labplot-kf5-2.1.0.tar.xz
+ md5sums = 7ca4deb2a009f0da4349fda695a43788
+
+pkgname = labplot-kf5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7206ee86662
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: b00rt00s ( bomby dot zrzuc at gmail dot com )
+
+pkgname=labplot-kf5
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="A free software data analysis and visualization application"
+arch=('i686' 'x86_64')
+url='http://labplot.sourceforge.net/'
+license=('GPL')
+depends=('gsl')
+makedepends=('cmake' 'extra-cmake-modules')
+source=("http://ftp.pbone.net/pub/kde/stable/labplot/2.1.0/src/labplot-kf5-2.1.0.tar.xz")
+md5sums=('7ca4deb2a009f0da4349fda695a43788')
+
+
+build() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+
+}
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}