summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2022-02-17 16:50:10 +0100
committerNarrat2022-02-17 16:50:10 +0100
commitb86a71d8798aaf512d79f46d8b193fb692ce9b5f (patch)
treecab9c7ac05c5a8eed0e61fc5549f404b34d964de
parente16d0f5477424ef6654d8f6d8156754d4fa5c957 (diff)
downloadaur-b86a71d8798aaf512d79f46d8b193fb692ce9b5f.tar.gz
labwc: fix build with wlroots 0.15.1
-rw-r--r--.SRCINFO4
-rw-r--r--0001_wlroots-version.patch24
-rw-r--r--PKGBUILD13
3 files changed, 37 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 457b2ca2907b..fbf8d0be62b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = labwc
pkgdesc = stacking wayland compositor with look and feel from openbox
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/johanmalm/labwc
arch = x86_64
license = GPL2
@@ -15,6 +15,8 @@ pkgbase = labwc
depends = xorg-xwayland
optdepends = bemenu: default launcher via Alt+F3
source = labwc-0.4.0.tar.gz::https://github.com/johanmalm/labwc/archive/0.4.0.tar.gz
+ source = 0001_wlroots-version.patch
b2sums = 737636488fdbd273d5ac2f90d63b3924edd257443ca1d857799ec81f1bcf540819e9d9b0cc06e1eb18a8db1f7c524c54606998aedeec3789529df73779062844
+ b2sums = 3b5ea923ce5eab50caaf9a71de0ca4eb073fc5293fbf62f979a25d158b721d0ca9bae5516a65c6dddf1f89e3771f72228a0287776a256796211294214ae1d796
pkgname = labwc
diff --git a/0001_wlroots-version.patch b/0001_wlroots-version.patch
new file mode 100644
index 000000000000..2bb01027e707
--- /dev/null
+++ b/0001_wlroots-version.patch
@@ -0,0 +1,24 @@
+commit 6a3536cdd74ec1d73475daec166b14c03ce14a8a
+Author: Michael Weiss <dev.primeos@gmail.com>
+Date: Fri Feb 4 21:17:05 2022 +0100
+
+ build: Relax the version constraint for wlroots to accept patch releases
+
+ Patch releases only contain backwards compatible changes (mainly bug
+ fixes) so we want to allow them. This fixes the build with the recently
+ released wlroots 0.15.1 and uses the same version constraints as other
+ projects that depend on wlroots (e.g., Sway).
+
+diff --git a/meson.build b/meson.build
+index f950b8e..1905dda 100644
+--- a/meson.build
++++ b/meson.build
+@@ -37,7 +37,7 @@ if git.found()
+ endif
+ add_project_arguments('-DLABWC_VERSION=@0@'.format(version), language: 'c')
+
+-wlroots_version = ['=0.15.0']
++wlroots_version = ['>=0.15.0', '<0.16.0']
+ wlroots_proj = subproject(
+ 'wlroots',
+ default_options: ['default_library=static', 'examples=false'],
diff --git a/PKGBUILD b/PKGBUILD
index fc2bca34714a..72b3da3aa3c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=labwc
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='stacking wayland compositor with look and feel from openbox'
url="https://github.com/johanmalm/labwc"
arch=('x86_64')
@@ -10,10 +10,17 @@ license=('GPL2')
depends=('pango' 'wlroots>=0.15' 'wlroots<0.16' 'wayland' 'wayland-protocols' 'xorg-xwayland')
makedepends=('meson' 'scdoc')
optdepends=("bemenu: default launcher via Alt+F3")
-source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/johanmalm/labwc/archive/${pkgver}.tar.gz")
-b2sums=('737636488fdbd273d5ac2f90d63b3924edd257443ca1d857799ec81f1bcf540819e9d9b0cc06e1eb18a8db1f7c524c54606998aedeec3789529df73779062844')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/johanmalm/labwc/archive/${pkgver}.tar.gz"
+ 0001_wlroots-version.patch)
+b2sums=('737636488fdbd273d5ac2f90d63b3924edd257443ca1d857799ec81f1bcf540819e9d9b0cc06e1eb18a8db1f7c524c54606998aedeec3789529df73779062844'
+ '3b5ea923ce5eab50caaf9a71de0ca4eb073fc5293fbf62f979a25d158b721d0ca9bae5516a65c6dddf1f89e3771f72228a0287776a256796211294214ae1d796')
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np1 -i "${srcdir}"/0001_wlroots-version.patch
+}
+
build() {
cd "$pkgname-$pkgver"
arch-meson -Dman-pages=enabled ../build