summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2022-03-15 23:21:06 +0100
committerNarrat2022-03-15 23:21:06 +0100
commitd8c01213e380caaf6e05ca532868a947b6622fa4 (patch)
tree45759b4b5f3b7da464ba822a302dd226a70af141
parent03783cbdec5ab74e7433677758e8bd1900d6297c (diff)
downloadaur-d8c01213e380caaf6e05ca532868a947b6622fa4.tar.gz
labwc: Follow guidelines more closely
in regards how to handle meson based sources
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c05b3e069356..eb00617f6a9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,12 +15,10 @@ b2sums=('bb7008b60e180fa9f936cb2a09e4ce616e70c2238dceb32e29f4cd8396a2ca2f0f58b43
build() {
- cd "$pkgname-$pkgver"
- arch-meson -Dman-pages=enabled ../build
- ninja -v -C ../build
+ arch-meson -Dman-pages=enabled "$_pkgname" build
+ meson compile -C build
}
package() {
- cd "$pkgname-$pkgver"
- DESTDIR="${pkgdir}" meson install -C ../build
+ meson install -C build --destdir "$pkgdir"
}