summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2022-12-29 00:11:27 +0100
committerNarrat2022-12-29 00:11:27 +0100
commite8d1b2f3ad0289e85bf5548caf81c6fa1977c961 (patch)
treefa93c22ed8156e9e8fbcdaf5cebf68c854e240f0
parentdb357c585cb639b49643dcbb304bada8eb81a22e (diff)
downloadaur-e8d1b2f3ad0289e85bf5548caf81c6fa1977c961.tar.gz
labwc-git: build without dynamic wlroots
forgot that this option exists...
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 018b5293f0d3..3a9a3722936e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = labwc-git
pkgdesc = stacking wayland compositor with look and feel from openbox (git version)
- pkgver = 0.5.0.r76.g5fd5024
- pkgrel = 2
+ pkgver = 0.6.0.r66.g63632cf
+ pkgrel = 1
url = https://github.com/labwc/labwc
arch = x86_64
license = GPL2
@@ -9,10 +9,10 @@ pkgbase = labwc-git
makedepends = meson
makedepends = scdoc
makedepends = wayland-protocols
+ makedepends = vulkan-headers
+ makedepends = xorgproto
depends = pango
depends = seatd
- depends = wlroots>=0.16
- depends = wlroots<0.17
depends = wayland
depends = xorg-xwayland
optdepends = bemenu: default launcher via Alt+F3
diff --git a/PKGBUILD b/PKGBUILD
index d8724dc5749a..08f7ef76fc70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
_pkgname=labwc
pkgname=labwc-git
-pkgver=0.5.0.r76.g5fd5024
-pkgrel=2
+pkgver=0.6.0.r66.g63632cf
+pkgrel=1
pkgdesc='stacking wayland compositor with look and feel from openbox (git version)'
url="https://github.com/labwc/labwc"
arch=('x86_64')
license=('GPL2')
-depends=('pango' 'seatd' 'wlroots>=0.16' 'wlroots<0.17' 'wayland' 'xorg-xwayland')
+depends=('pango' 'seatd' 'wayland' 'xorg-xwayland')
makedepends=('git' 'meson' 'scdoc' 'wayland-protocols')
+makedepends+=('vulkan-headers' 'xorgproto') # for latest compatible wlroots
optdepends=("bemenu: default launcher via Alt+F3")
conflicts=(labwc)
provides=(labwc)
@@ -22,8 +23,12 @@ pkgver() {
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ meson subprojects download wlroots --sourcedir="$_pkgname"
+}
+
build() {
- arch-meson -Dman-pages=enabled "$_pkgname" build
+ arch-meson -Dman-pages=enabled "$_pkgname" build --force-fallback-for=wlroots
meson compile -C build
}