summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredtide2023-07-01 15:42:33 +0200
committerredtide2023-07-01 15:59:41 +0200
commita9305a0382051a726762445ff17ad4a9ab29ad0b (patch)
treee67d752b3c82a4ab2314bc1bd74ac9a51aeb2a32
downloadaur-a9305a0382051a726762445ff17ad4a9ab29ad0b.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--.editorconfig14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD42
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6135ff1209f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = labwc-tweaks-git
+ pkgdesc = Simple configuration GUI application for labwc
+ pkgver = r57.c52dc16
+ pkgrel = 1
+ url = https://github.com/labwc/labwc-tweaks
+ arch = x86_64
+ license = GPL2
+ makedepends = meson
+ depends = gtk3
+ depends = libxml2
+ depends = wayland
+ depends = wayland-protocols
+ source = labwc-tweaks::git+https://github.com/labwc/labwc-tweaks.git
+ sha512sums = SKIP
+
+pkgname = labwc-tweaks-git
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..b4e2598065da
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,14 @@
+# EditorConfig configuration
+# http://editorconfig.org
+
+# Top-most EditorConfig file
+root = true
+
+# UTF-8 charset, set indent to spaces with width of four,
+# with no trailing whitespaces and a newline ending every file.
+[*]
+charset = utf-8
+indent_size = 2
+indent_style = space
+insert_final_newline = true
+trim_trailing_whitespace = true
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..475395cc0980
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.editorconfig
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3d30ad06c30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: redtide <redtid3@gmail.com>
+
+_pkgname=labwc-tweaks
+pkgname=$_pkgname-git
+pkgver=r57.c52dc16
+pkgrel=1
+pkgdesc="Simple configuration GUI application for labwc"
+url="https://github.com/labwc/labwc-tweaks"
+license=(GPL2)
+arch=(x86_64)
+depends=(
+ gtk3
+ libxml2
+ wayland
+ wayland-protocols
+)
+makedepends=(
+ meson
+)
+source=(
+ $_pkgname::git+$url.git
+)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$_pkgname"
+ arch-meson "$srcdir/build"
+ ninja -C "$srcdir/build"
+}
+
+package() {
+ cd "$_pkgname"
+ DESTDIR="$pkgdir" ninja -C "$srcdir/build" install
+}