summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorholybaechu2024-03-16 17:44:57 +0900
committerholybaechu2024-03-16 17:44:57 +0900
commitb6a090cfcf750246c9bbf73066bc4fcb83bb9b39 (patch)
tree7a61d780e87b31173ff7c48a5deafb8b8414e506
parente6b40541f6431b66fac42d22e47af80a071c82b8 (diff)
downloadaur-b6a090cfcf750246c9bbf73066bc4fcb83bb9b39.tar.gz
Fix mount error
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD61
2 files changed, 33 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 561c4adfb3b8..0f1c2ef6cf67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = labymod-appimage
- pkgdesc = A minecraft Launcher & modpack that optimizes the game and adds a bunch of useful features ! (1.8->1.20.1)
+ pkgdesc = A minecraft Launcher & modpack that optimizes the game and adds a bunch of useful features ! (1.8.9->1.20.4)
pkgver = 2.0.12
- pkgrel = 1
+ pkgrel = 2
url = https://www.labymod.net
arch = x86_64
license = unknown
diff --git a/PKGBUILD b/PKGBUILD
index 56e2c0f34efe..5404ac0a80b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Nixugea
+# Maintainer: holybaechu <holyb@holyb.xyz>
# As of 1.0.32, the hash check is skipped.
# Labymod unfortunately does not provide version specific download links.
@@ -13,7 +14,7 @@
pkgname=labymod-appimage
_pkgname=labymodlauncher
pkgver=2.0.12
-pkgrel=1
+pkgrel=2
pkgdesc='A minecraft Launcher & modpack that optimizes the game and adds a bunch of useful features ! (1.8->1.20.1)'
url=https://www.labymod.net
arch=(x86_64)
@@ -25,39 +26,39 @@ source=("https://releases.r2.labymod.net/launcher/linux/x64/LabyMod%20Launcher-l
sha256sums=('SKIP')
prepare() {
- chmod +x "${_appimage}"
- ./"${_appimage}" --appimage-extract
+ chmod +x "${_appimage}"
+ ./"${_appimage}" --appimage-extract
}
build() {
- # Adjust .desktop so it will work outside of AppImage container
- sed -i -E \
- "s|Exec=AppRun|Exec=env DESKTOPINTEGRATION=false /usr/bin/${_pkgname}|" \
- "squashfs-root/${_pkgname}.desktop"
- # Fix permissions; .AppImage permissions are 700 for all directories
- chmod -R a-x+rX squashfs-root/usr
+ # Adjust .desktop so it will work outside of AppImage container
+ sed -i -E \
+ "s|Exec=AppRun|Exec=env DESKTOPINTEGRATION=false /usr/bin/${_pkgname}|" \
+ "squashfs-root/${_pkgname}.desktop"
+ # Fix permissions; .AppImage permissions are 700 for all directories
+ chmod -R a-x+rX squashfs-root/usr
}
package() {
- # AppImage
- install -Dm755 \
- "${srcdir}/${_appimage}" \
- "${pkgdir}/opt/${_pkgname}/${_pkgname}.AppImage"
-
- # Desktop file
- install -Dm644 \
- "${srcdir}/squashfs-root/${_pkgname}.desktop" \
- "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
-
- # Icon images
- install -dm755 "${pkgdir}/usr/share/"
- cp -a \
- "${srcdir}/squashfs-root/usr/share/icons" \
- "${pkgdir}/usr/share/"
-
- # Symlink executable
- install -dm755 "${pkgdir}/usr/bin"
- ln -s \
- "/opt/${_pkgname}/${_pkgname}.AppImage" \
- "${pkgdir}/usr/bin/${_pkgname}"
+ # AppImage
+ sudo cp -a \
+ "${srcdir}/squashfs-root/." \
+ "/opt/${_pkgname}/"
+
+ # Desktop file
+ install -Dm644 \
+ "/opt/${_pkgname}/${_pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ # Icon images
+ install -dm755 "${pkgdir}/usr/share/"
+ ln -s \
+ "${pkgdir}/usr/share" \
+ "/opt/${_pkgname}/usr/share/icons"
+
+ # Symlink executable
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s \
+ "/opt/${_pkgname}/labymodlauncher" \
+ "${pkgdir}/usr/bin/${_pkgname}"
}