summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2015-07-08 00:43:29 -0700
committerLlewelyn Trahaearn2015-07-08 00:43:29 -0700
commit1da631e1c2e8cd60a9f2155ffc12da40e6d6c120 (patch)
treeba97fac19e40c262a6aa6e9180efa63623dd6823
downloadaur-1da631e1c2e8cd60a9f2155ffc12da40e6d6c120.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD48
-rw-r--r--ladish-git.install12
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ca4d179c1c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ladish-git
+ pkgdesc = Session management system for JACK.
+ pkgver = 0.3.r147.g5fe205f
+ pkgrel = 1
+ url = https://launchpad.net/ladish
+ install = ladish-git.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = python2
+ depends = jack2-dbus
+ depends = dbus-glib
+ depends = laditools-git
+ depends = flowcanvas<=0.7.1
+ depends = a2jmidid
+ provides = ladish
+ provides = lash
+ conflicts = ladish
+ conflicts = lash
+ source = git://repo.or.cz/ladish.git
+ md5sums = SKIP
+
+pkgname = ladish-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0713fd3f23de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: WoefulDerelict <WoefulDerelict at GMail dot com>
+# Contributor: speps <speps at aur dot archlinux dot org>
+_pkgname=ladish
+pkgname=${_pkgname}-git
+pkgver=0.3.r147.g5fe205f
+pkgrel=1
+pkgdesc="Session management system for JACK."
+arch=('any')
+url="https://launchpad.net/ladish"
+license=('GPL2')
+depends=('jack2-dbus' 'dbus-glib' 'laditools-git' 'flowcanvas<=0.7.1' 'a2jmidid')
+makedepends=('git' 'python2')
+provides=("${_pkgname}" "lash")
+conflicts=("${_pkgname}" "lash")
+install=${pkgname}.install
+source=("git://repo.or.cz/${_pkgname}.git")
+md5sums=('SKIP')
+
+_branch=master
+
+pkgver() {
+ cd ${srcdir}/${_pkgname}
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/^ladish-//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ git checkout ${_branch}
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ export PYTHON=/usr/bin/python2
+ sed -i "s|env python|&2|" ${_pkgname}_control
+ sed -i "s|\(RELEASE = \).*|\1True|" wscript
+ python2 waf configure --prefix=/usr \
+ --enable-liblash \
+ --enable-pylash
+ python2 waf
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python2 waf install --destdir="${pkgdir}/"
+}
diff --git a/ladish-git.install b/ladish-git.install
new file mode 100644
index 000000000000..bce670aff4af
--- /dev/null
+++ b/ladish-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}