summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2023-10-12 09:06:28 -0700
committerLlewelyn Trahaearn2023-10-12 09:06:28 -0700
commit5218dbb4956faf625c9a767b4166c3df4512df5f (patch)
treed2fe7c836420b9974e5d808695a85bbc108e149e
parenta1280b8b3d7479ef4d2a741e26aa1dc915295414 (diff)
downloadaur-5218dbb4956faf625c9a767b4166c3df4512df5f.tar.gz
Update URL and source to current project location.
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD45
2 files changed, 38 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc488df3b0ec..127ad9c6faa1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,32 @@
-# Generated by mksrcinfo v8
-# Sat Jan 27 19:42:32 UTC 2018
pkgbase = ladish-git
pkgdesc = Session management system for JACK.
- pkgver = 1.r49.gc5f340d0
+ pkgver = 1.r126.g71c8e1cf
pkgrel = 1
- url = https://github.com/LADI/ladish
+ url = https://ladish.org
arch = i686
arch = x86_64
license = GPL2
+ license = custom:AFL2.1
+ makedepends = boost
makedepends = git
makedepends = intltool
depends = a2jmidid
- depends = boost
+ depends = cdbus
depends = dbus-glib
- depends = flowcanvas<=0.7.1
- depends = jack
- depends = laditools-git
- depends = python2
+ depends = dbus-python
+ depends = expat
+ depends = glibc
+ depends = gtkmm
+ depends = jack2-dbus
+ depends = libgnomecanvasmm
+ depends = python
+ depends = util-linux-libs
+ optdepends = laditools: Provides ladi-control-center the default JACK configuration tool in gladish
provides = ladish
provides = lash
conflicts = ladish
conflicts = lash
- source = ladish::git+https://github.com/alessio/ladish.git
- sha512sums = SKIP
+ source = ladish::git+https://gitea.ladish.org/LADI/ladish.git
+ sha256sums = SKIP
pkgname = ladish-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4c4facd94b81..70ed3eb5f25c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,20 @@
-# Maintainer: WoefulDerelict <WoefulDerelict at GMail dot com>
+# Contributor: WoefulDerelict <WoefulDerelict at GMail dot com>
# Contributor: speps <speps at aur dot archlinux dot org>
pkgname=ladish-git
-pkgver=1.r49.gc5f340d0
+pkgver=1.r126.g71c8e1cf
pkgrel=1
pkgdesc="Session management system for JACK."
arch=('i686' 'x86_64')
-url="https://github.com/LADI/ladish"
-license=('GPL2')
-depends=('a2jmidid' 'boost' 'dbus-glib' 'flowcanvas<=0.7.1' 'jack' 'laditools-git' 'python2')
-makedepends=('git' 'intltool')
+url="https://ladish.org"
+license=('GPL2' 'custom:AFL2.1')
+depends=('a2jmidid' 'cdbus' 'dbus-glib' 'dbus-python' 'expat' 'glibc' 'gtkmm' 'jack2-dbus' 'libgnomecanvasmm' 'python' 'util-linux-libs')
+makedepends=('boost' 'git' 'intltool')
+optdepends=('laditools: Provides ladi-control-center the default JACK configuration tool in gladish')
provides=("${pkgname%-*}" 'lash')
conflicts=("${pkgname%-*}" 'lash')
-source=("${pkgname%-*}::git+https://github.com/alessio/ladish.git")
-sha512sums=('SKIP')
-_branch=master
-
-prepare() {
- cd "${pkgname%-*}"
- git checkout ${_branch}
- sed -i "s|env python|&2|" ladish_control
- sed -i "s|\(RELEASE = \).*|\1True|" wscript
-}
+source=("${pkgname%-*}::git+https://gitea.ladish.org/LADI/ladish.git")
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-*}"
@@ -33,15 +26,21 @@ pkgver() {
build() {
cd "${pkgname%-*}"
- export PYTHON=/usr/bin/python2
- export CXX='g++ -std=c++11'
- python2 waf configure --prefix=/usr \
- --enable-liblash \
- --enable-pylash
- python2 waf
+# The meson build currently lacks key files, including the dbus .service files, and is not ready for deployment.
+# When migrating add 'meson' and 'cmake' to the makedepends array.
+
+# meson setup --prefix /usr --auto-features enabled --wrap-mode nodownload -D b_lto=true -D b_pie=true -D python.bytecompile=1 build
+# meson compile -C build
+
+ ./waf configure --prefix=/usr \
+ --enable-gladish \
+ --enable-liblash
+ ./waf
}
package() {
cd "${pkgname%-*}"
- python2 waf install --destdir="${pkgdir}/"
+# meson install -C build --destdir "$pkgdir"
+ ./waf install --destdir="${pkgdir}"
+ install -Dm644 afl21.txt "$pkgdir/usr/share/licenses/$pkgname/AFL-2.1.txt"
}