summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2018-01-27 11:43:14 -0800
committerLlewelyn Trahaearn2018-01-27 11:43:14 -0800
commita1280b8b3d7479ef4d2a741e26aa1dc915295414 (patch)
tree8bec0182479781baed2cbe1f80817108577f82f6
parent7f9683eb39743eab630c604b7f8349c02ca9f248 (diff)
downloadaur-a1280b8b3d7479ef4d2a741e26aa1dc915295414.tar.gz
Swap to alessio's fork with conf tool patch.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8183906c447..bc488df3b0ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon May 15 22:13:47 UTC 2017
+# Sat Jan 27 19:42:32 UTC 2018
pkgbase = ladish-git
pkgdesc = Session management system for JACK.
- pkgver = 1.r47.g5fe205f2
+ pkgver = 1.r49.gc5f340d0
pkgrel = 1
url = https://github.com/LADI/ladish
arch = i686
@@ -21,7 +21,7 @@ pkgbase = ladish-git
provides = lash
conflicts = ladish
conflicts = lash
- source = ladish-git::git+https://github.com/LADI/ladish.git
+ source = ladish::git+https://github.com/alessio/ladish.git
sha512sums = SKIP
pkgname = ladish-git
diff --git a/PKGBUILD b/PKGBUILD
index b5d7f8d298b2..4c4facd94b81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: speps <speps at aur dot archlinux dot org>
pkgname=ladish-git
-pkgver=1.r47.g5fe205f2
+pkgver=1.r49.gc5f340d0
pkgrel=1
pkgdesc="Session management system for JACK."
arch=('i686' 'x86_64')
@@ -12,19 +12,19 @@ depends=('a2jmidid' 'boost' 'dbus-glib' 'flowcanvas<=0.7.1' 'jack' 'laditools-gi
makedepends=('git' 'intltool')
provides=("${pkgname%-*}" 'lash')
conflicts=("${pkgname%-*}" 'lash')
-source=("${pkgname}::git+https://github.com/LADI/ladish.git")
+source=("${pkgname%-*}::git+https://github.com/alessio/ladish.git")
sha512sums=('SKIP')
_branch=master
prepare() {
- cd "${pkgname}"
+ cd "${pkgname%-*}"
git checkout ${_branch}
sed -i "s|env python|&2|" ladish_control
sed -i "s|\(RELEASE = \).*|\1True|" wscript
}
pkgver() {
- cd "${pkgname}"
+ cd "${pkgname%-*}"
( set -o pipefail
git describe --long --tags 2>/dev/null | sed 's/^ladish.//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -32,7 +32,7 @@ pkgver() {
}
build() {
- cd "${pkgname}"
+ cd "${pkgname%-*}"
export PYTHON=/usr/bin/python2
export CXX='g++ -std=c++11'
python2 waf configure --prefix=/usr \
@@ -42,6 +42,6 @@ build() {
}
package() {
- cd "${pkgname}"
+ cd "${pkgname%-*}"
python2 waf install --destdir="${pkgdir}/"
}