summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2018-01-27 11:29:33 -0800
committerLlewelyn Trahaearn2018-01-27 11:29:33 -0800
commit743e8dd9efa444ba7337d2963891e210a442bc5d (patch)
tree2b2580e7de39508ab2e9feaa7aafcc2ebba467a6
parent8023147809450bc9b092f289403f1ce849ed0134 (diff)
downloadaur-743e8dd9efa444ba7337d2963891e210a442bc5d.tar.gz
Switch to alessio's updated fork and include the python2-enum34 port.
-rw-r--r--PKGBUILD23
-rw-r--r--enum34.diff28
2 files changed, 43 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8eb386bfce55..d92f65ed7fae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,30 @@
# Maintainer: WoefulDerelict <WoefulDerelict at GMail dot com>
pkgname=laditools
-pkgver=1.0.1
-pkgrel=2
+pkgver=1.1.0
+pkgrel=1
pkgdesc="Utilities to improve integration and workflow with JACK and LASH."
arch=('any')
-url="https://launchpad.net/laditools"
+url="https://github.com/LADI/laditools"
license=('GPL3')
-depends=('glade' 'jack' 'pygtk' 'python2' 'python2-enum' 'python2-yaml')
+depends=('glade' 'jack' 'pygtk' 'python2' 'python2-enum34' 'python2-yaml')
makedepends=('git' 'python2-distutils-extra')
-source=("http://repo.or.cz/w/laditools.git/snapshot/2b3f5356ac5a79bcb5184498e49f3d6ea3943f14.tar.gz")
-sha512sums=('3cc54e2251b244c64f9f28560cf6a03343139b1ea3e227004cd54310517ac4e4ddccae088de93fab91f934d403d084dee25c2d31b5818b4349268feafdb084b0')
+source=("https://github.com/alessio/laditools/archive/v${pkgver}.tar.gz"
+ "enum34.diff")
+sha512sums=('7f56d669cc1e468e0aa68b541f0da8b98cfdcceb6fd9e55a054d7622c4066f6422d367034697a4838bcd2f2caf14a1281f66b70f6ff4adff7de3c91f51f1bcdb'
+ 'b406924a4b59ec15e7db4af926d7ec1e8c8802cede7d77d8d524592aa99c858e24cc9ce5f513d592dbecb9f3614404250e5a7963425d00b435cd8f6eb103a362')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -Np1 -i ${srcdir}/enum34.diff
+}
build() {
- cd "${srcdir}/${pkgname}-2b3f535"
+ cd "${pkgname}-${pkgver}"
python2 setup.py build
}
package() {
- cd "${srcdir}/${pkgname}-2b3f535"
+ cd "${pkgname}-${pkgver}"
python2 setup.py install --prefix=/usr --root="${pkgdir}/"
}
diff --git a/enum34.diff b/enum34.diff
new file mode 100644
index 000000000000..08d735132ea5
--- /dev/null
+++ b/enum34.diff
@@ -0,0 +1,28 @@
+diff -Naur laditools-1.1.0.orig/INSTALL laditools-1.1.0/INSTALL
+--- laditools-1.1.0.orig/INSTALL 2015-09-13 14:38:51.000000000 -0700
++++ laditools-1.1.0/INSTALL 2018-01-27 10:23:41.606495560 -0800
+@@ -29,7 +29,7 @@
+ Plus, the following dependencies must be satisfied:
+
+ - GTK+3 (>= 3.2.2, http://www.gtk.org/)
+- - python-enum (>= 0.4.4, http://pypi.python.org/pypi/enum/)
++ - python-enum34 (>= 1.1.2, https://pypi.python.org/pypi/enum34/)
+ - VTE (>= 0.30.1, http://ftp.gnome.org/pub/GNOME/sources/vte/)
+
+ Here is a list of optional dependencies:
+diff -Naur laditools-1.1.0.orig/laditools/ladish.py laditools-1.1.0/laditools/ladish.py
+--- laditools-1.1.0.orig/laditools/ladish.py 2015-09-13 14:38:51.000000000 -0700
++++ laditools-1.1.0/laditools/ladish.py 2018-01-27 10:23:41.629828859 -0800
+@@ -28,10 +28,8 @@
+ studio_obj_path = "/org/ladish/Studio"
+ service_name = name_base
+
+-LadishStatusType = Enum("STUDIO_STOPPED",
+- "NOT_AVAILABLE",
+- "NO_STUDIO_LOADED",
+- "STUDIO_RUNNING")
++LadishStatusType = Enum("LadishStatusType",
++ "STUDIO_STOPPED NOT_AVAILABLE NO_STUDIO_LOADED STUDIO_RUNNING")
+
+ class LadishProxyError(Exception): pass
+ class LadishStudioException(Exception): pass