summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-06-30 13:29:24 -0400
committerTed Alff2017-06-30 13:29:24 -0400
commit344e78cb9d94b078c577b6daa57ca056c8ab3145 (patch)
treea47bae702ba8ed5bad6fb57ddfc3c8ce775c8907
downloadaur-344e78cb9d94b078c577b6daa57ca056c8ab3145.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ab9f2a1feb1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Jun 30 17:29:16 UTC 2017
+pkgbase = ladon
+ pkgdesc = Utility to process mary files in parallel
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = https://github.com/danielgtaylor/ladon
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ source = ladon-1.0.6.tar.gz::https://github.com/danielgtaylor/ladon/archive/1.0.6.tar.gz
+ sha256sums = 86b49c434931b99547f6415e5369f541cdb0c99beb8a46af3efbe472ff37d89e
+
+pkgname = ladon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf424c8624a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+#Maintainer twa022 <twa022 at gmail dot com>
+
+pkgname=ladon
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="Utility to process mary files in parallel"
+url="https://github.com/danielgtaylor/ladon"
+arch=('any')
+license=('MIT')
+depends=('nodejs')
+makedepends=('npm')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('86b49c434931b99547f6415e5369f541cdb0c99beb8a46af3efbe472ff37d89e')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ npm install --production
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ mkdir -p "${pkgdir}"/usr/{bin,lib/ladon}
+ cp -ar --no-preserve=ownership ladon.js node_modules package.json "${pkgdir}/usr/lib/ladon"
+
+ cat > "${pkgdir}"/usr/bin/ladon <<- __EOF__
+ #!/bin/bash
+ /usr/lib/ladon/ladon.js "\$@"
+ __EOF__
+ chmod 755 "${pkgdir}"/usr/bin/ladon
+}