summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelipe Barriga Richards2017-01-19 15:19:52 -0300
committerFelipe Barriga Richards2017-01-19 15:19:52 -0300
commit2298ad693ef17b47579bdfa8c663c4e3041d0927 (patch)
treef230a610befeb868929fc25d038c7c55cf71ffd4
downloadaur-2298ad693ef17b47579bdfa8c663c4e3041d0927.tar.gz
initial commit.
-rw-r--r--.SRCINFO21
-rw-r--r--0001-bugfix-lag.cpp-fix-opengl-context-creation.patch29
-rw-r--r--PKGBUILD41
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0517b777c09f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = lag-git
+ pkgdesc = LAG is a software for visualisation, analysis and processing of LiDAR data.
+ pkgver = r384.6b0b2fb
+ pkgrel = 1
+ url = https://github.com/arsf/lag
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = laslib-git
+ depends = lidarquadtree-git
+ depends = boost
+ depends = gtkmm
+ depends = gtkglextmm
+ depends = libgeotiff
+ source = git+https://github.com/arsf/lag.git
+ source = 0001-bugfix-lag.cpp-fix-opengl-context-creation.patch
+ md5sums = SKIP
+ md5sums = 794eb60e1fcb9bfcc5a934a70709d87f
+
+pkgname = lag-git
+
diff --git a/0001-bugfix-lag.cpp-fix-opengl-context-creation.patch b/0001-bugfix-lag.cpp-fix-opengl-context-creation.patch
new file mode 100644
index 000000000000..01db82681b7d
--- /dev/null
+++ b/0001-bugfix-lag.cpp-fix-opengl-context-creation.patch
@@ -0,0 +1,29 @@
+From 53e9fcf99e0b2dad3fcc4cf7c2d1210d022e4c0a Mon Sep 17 00:00:00 2001
+From: Felipe Barriga Richards <spam@felipebarriga.cl>
+Date: Thu, 19 Jan 2017 14:13:15 -0300
+Subject: [PATCH] bugfix: lag.cpp: fix opengl context creation.
+
+---
+ src/lag.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/lag.cpp b/src/lag.cpp
+index 06b9569..12dc755 100644
+--- a/src/lag.cpp
++++ b/src/lag.cpp
+@@ -179,10 +179,10 @@ int main(int argc, char** argv)
+ Glib::RefPtr < Gdk::GL::Config > glconfig;
+
+ glconfig = Gdk::GL::Config::create(Gdk::GL::MODE_RGB | Gdk::GL::MODE_DEPTH | Gdk::GL::MODE_DOUBLE);
+- if(glconfig == 0)
++ if(!glconfig)
+ {
+ glconfig = Gdk::GL::Config::create(Gdk::GL::MODE_RGB | Gdk::GL::MODE_DEPTH);
+- if(glconfig == 0)
++ if(!glconfig)
+ {
+ cout << "Cannot intialise OpenGL. Exiting." << endl;
+ std::exit(1);
+--
+2.11.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7ddc16102c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Felipe Barriga Richards < felipe at felipebarriga DOT cl >
+pkgname=lag-git
+_pkgver="6b0b2fb"
+pkgver="r384.$_pkgver"
+pkgrel=1
+pkgdesc="LAG is a software for visualisation, analysis and processing of LiDAR data."
+arch=('i686' 'x86_64')
+url="https://github.com/arsf/lag"
+license=('GPL2')
+source=("git+https://github.com/arsf/lag.git" 0001-bugfix-lag.cpp-fix-opengl-context-creation.patch)
+md5sums=('SKIP' '794eb60e1fcb9bfcc5a934a70709d87f')
+depends=(laslib-git lidarquadtree-git boost gtkmm gtkglextmm libgeotiff)
+pkgver() {
+ cd "$srcdir/lag"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/lag"
+ patch -p1 < "$srcdir/0001-bugfix-lag.cpp-fix-opengl-context-creation.patch"
+
+ libtoolize
+ autoheader
+ aclocal
+ automake --add-missing
+ autoconf
+ # when laslib-git package is fixed to be installed
+ # on /usr change the following lines...
+ export laslib_CFLAGS=-I/usr/local/include
+ export laslib_LIBS=-L/usr/lib
+ export lidarquadtree_CFLAGS=-I/usr/include/lidar/quadtree
+ export lidarquadtree_LIBS=-llidarquadtree
+
+ ./configure --prefix=/usr LIBS="-ldl /usr/lib/liblaslib.a"
+ make
+}
+
+package() {
+ cd "$srcdir/lag"
+ make DESTDIR=$pkgdir install
+}