summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Capezzuto2022-03-24 18:55:45 -0600
committerLuca Capezzuto2022-03-24 18:55:45 -0600
commit3683fcbd6c88306dcf41036f4bc742fbb26d3cbd (patch)
treeab24c8e85e321a3208a4e19c78e90adf21305698
parente87bb65a3b97b732ce991858ef9b43d46f15778e (diff)
downloadaur-lain-git.tar.gz
update dkjson to v2.6
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 375151dc963e..ec6f8cd9eaef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = lain-git
pkgdesc = Layouts, asynchronous widgets and utilities for Awesome WM
- pkgver = 1771.07cf82e
+ pkgver = r1771.07cf82e
pkgrel = 1
+ epoch = 1
url = https://github.com/lcpz/lain
arch = any
license = GPL2
+ makedepends = git
depends = awesome
optdepends = curl: for IMAP, MPD and weather widgets
provides = lain
conflicts = lain
- source = lain-1771.07cf82e.zip::https://github.com/lcpz/lain/archive/07cf82e.zip
+ source = git+https://github.com/lcpz/lain.git
sha256sums = SKIP
pkgname = lain-git
diff --git a/PKGBUILD b/PKGBUILD
index 6c1328d5d840..0c197986ab6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,28 @@
_pkgname=lain
pkgname=$_pkgname-git
-pkgcom=1771
-pkgsha=07cf82e
-pkgver=$pkgcom.$pkgsha
+pkgver=r1771.07cf82e
pkgrel=1
+epoch=1
pkgdesc="Layouts, asynchronous widgets and utilities for Awesome WM"
arch=("any")
url="https://github.com/lcpz/$_pkgname"
license=("GPL2")
depends=("awesome")
+makedepends=("git")
optdepends=("curl: for IMAP, MPD and weather widgets")
provides=("$_pkgname")
conflicts=("$_pkgname")
sha256sums=("SKIP")
-source=("$_pkgname-${pkgver}.zip::https://github.com/lcpz/$_pkgname/archive/$pkgsha.zip")
+source=("git+https://github.com/lcpz/lain.git")
-prepare() {
- rm -fr "$_pkgname/$_pkgname-$pkgsha"*
- mv "$_pkgname-$pkgsha"* $_pkgname
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd $_pkgname
+ cd "$_pkgname"
install -dm755 "$pkgdir/usr/share/lua/5.3/$_pkgname/"{icons,layout,util,widget}
cp -a {icons,layout,util,widget,LICENSE,README.rst,*.lua} "$pkgdir/usr/share/lua/5.3/$_pkgname"
}