summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca CPZ2020-11-27 12:43:03 +0000
committerLuca CPZ2020-11-27 12:43:03 +0000
commitf3abed16e6c6e3892818466fe7123be6962599f9 (patch)
tree9309b6f5833dafcf3ce7dd21b3b29f0f8cf325a0
parentb2f583114654a669dc0a73f6fbca8d9e517168e2 (diff)
parentcc1dd9e7d4b1ce9a099e5e9f3b61612cda91ef81 (diff)
downloadaur-f3abed16e6c6e3892818466fe7123be6962599f9.tar.gz
merged several PRs
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD44
2 files changed, 21 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30ef281c505d..b2f9a882de8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,13 +5,12 @@ pkgbase = lain-git
url = https://github.com/lcpz/lain
arch = any
license = GPL2
- makedepends = git
depends = awesome
optdepends = curl: for IMAP, MPD and weather widgets
provides = lain
conflicts = lain
- source = git://github.com/lcpz/lain.git
- md5sums = SKIP
+ source = lain-1735.a071cc5.zip::https://github.com/lcpz/lain/archive/a071cc5.zip
+ sha256sums = SKIP
pkgname = lain-git
diff --git a/PKGBUILD b/PKGBUILD
index 2ba7eefdd83a..14878e4998b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,29 @@
# Maintainer: Luca CPZ <luca.cpz [at] gmail [dot] com>
-pkgname=lain-git
+_pkgname=lain
+pkgname=$_pkgname-git
pkgcom=1735
pkgsha=a071cc5
pkgver=$pkgcom.$pkgsha
pkgrel=1
pkgdesc="Layouts, asynchronous widgets and utilities for Awesome WM"
-arch=('any')
-url="https://github.com/lcpz/lain"
-license=('GPL2')
-depends=('awesome')
-optdepends=('curl: for IMAP, MPD and weather widgets')
-makedepends=('git')
-provides=('lain')
-conflicts=('lain')
-source=("git://github.com/lcpz/lain.git")
-md5sums=('SKIP')
+arch=("any")
+url="https://github.com/lcpz/$_pkgname"
+license=("GPL2")
+depends=("awesome")
+optdepends=("curl: for IMAP, MPD and weather widgets")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+sha256sums=("SKIP")
+source=("$_pkgname-${pkgver}.zip::https://github.com/lcpz/$_pkgname/archive/$pkgsha.zip")
-package() {
- # check if awesome is stable or git
- if [ -d "/usr/share/awesome/lib/" ]; then
- aw_path="$pkgdir/usr/share/awesome/lib"
- else
- aw_path="$pkgdir/usr/local/share/awesome/lib"
- fi
-
- install -dm755 "$aw_path/lain"
- git --git-dir=lain/.git --work-tree=lain/ reset --hard $pkgsha --quiet
- rm -rf lain/{wiki,.git*,*.rockspec,*TEMPLATE*}
- cp -a lain $aw_path
+prepare() {
+ rm -fr "$_pkgname/$_pkgname-$pkgsha"*
+ mv "$_pkgname-$pkgsha"* $_pkgname
+}
- # fix scripts permissions
- find "$pkgdir" -type f ! -path "*/scripts/*" -print0 | xargs -0 chmod -R 644
+package() {
+ cd $_pkgname
+ install -dm755 "$pkgdir/usr/share/lua/5.3/$_pkgname/"{icons,layout,util,widget}
+ cp -a {icons,layout,util,widget,LICENSE,README.rst,*.lua} "$pkgdir/usr/share/lua/5.3/$_pkgname"
}