summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorosch2018-09-29 11:14:07 +0200
committerosch2018-09-29 11:14:07 +0200
commit949c5afe285b3f98ea0119927b529270f5b65174 (patch)
tree77001b02e216b2f9f3359b730599a47756c0b1aa
downloadaur-949c5afe285b3f98ea0119927b529270f5b65174.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fbe31fc05a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lake
+ pkgdesc = Lua-based Build Tool
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = https://github.com/stevedonovan/Lake
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = lua
+ depends = lua-filesystem
+ depends = lua-posix
+ source = lake-1.4.1.tar.gz::https://github.com/stevedonovan/Lake/archive/1.4.1.tar.gz
+ md5sums = 692ab4b24d307a81f5860b0f1ab681a3
+
+pkgname = lake
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad4c42311392
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: osch <oliver@luced.de>
+pkgname=lake
+pkgver=1.4.1
+pkgrel=1
+pkgdesc="Lua-based Build Tool"
+arch=("i686" "x86_64")
+url="https://github.com/stevedonovan/Lake"
+license=("MIT")
+depends=("lua" "lua-filesystem" "lua-posix")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/stevedonovan/Lake/archive/$pkgver.tar.gz")
+
+
+package() {
+ cd "$srcdir/Lake-$pkgver"
+
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 lake "$pkgdir/usr/bin/lake"
+}
+md5sums=('692ab4b24d307a81f5860b0f1ab681a3')