summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2017-10-24 14:26:45 +0100
committerWill Handley2017-10-24 14:26:45 +0100
commit62b996524b2ef8fec776eb00aea3650c2b626af1 (patch)
tree26190473fe612dacf96bee9f703026e2bf8fec54
parentb9c0749c1870ef05a419a72e03619b32df247042 (diff)
downloadaur-62b996524b2ef8fec776eb00aea3650c2b626af1.tar.gz
Reorganised check functions
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a97f8481e664..b41a7ba5981e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue Oct 24 13:26:45 UTC 2017
pkgbase = lalburst
pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. lalburst
pkgver = 1.4.4
- pkgrel = 4
+ pkgrel = 5
url = https://wiki.ligo.org/DASWG/LALSuiteInstall
arch = any
groups = lalsuite
diff --git a/PKGBUILD b/PKGBUILD
index eef8ec8bd045..6fade644d536 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=lalburst
_pkgname=${pkgname}
pkgver=1.4.4
-pkgrel=4
+pkgrel=5
pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. ${_pkgname}"
arch=(any)
url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
@@ -18,17 +18,20 @@ options=(!emptydirs)
install=
source=("http://software.ligo.org/lscsoft/source/lalsuite/${_pkgname}-${pkgver}.tar.xz")
sha256sums=('2fc15ecd5cf195c2794234977f2c320efbcab2f294a03f8b5eda9ac7edbc93f1')
-build() {
+prepare() {
cd "$srcdir/${_pkgname}-${pkgver}"
sed -i 's/\-Werror//g' configure
+}
+build() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
./configure --prefix=$pkgdir/usr CFLAGS=-O3
make -j
}
+check() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
+ make -j check
+}
package() {
cd "$srcdir/${_pkgname}-${pkgver}"
make install
}
-#check() {
-# cd "$srcdir/${_pkgname}-${pkgver}"
-# make -j check
-#}