summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2017-10-09 07:07:48 +0100
committerWill Handley2017-10-09 07:07:48 +0100
commit75a00747caeeea6fd419d012100ef06ed853b8b7 (patch)
treedf0595399e4394a4096c80e03e4670a969f6b543
parent4429d197f9705933a302609541f812f4aa62ee93 (diff)
downloadaur-75a00747caeeea6fd419d012100ef06ed853b8b7.tar.gz
Added checks
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0637ba77a3df..f25ed79db3d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lalburst
pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. lalburst
pkgver = 1.4.4
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.ligo.org/DASWG/LALSuiteInstall
arch = any
groups = lalsuite
diff --git a/PKGBUILD b/PKGBUILD
index 23e8bea960be..eb9ff98fd8ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
pkgname=lalburst
+_pkgname=${pkgname}
pkgver=1.4.4
-pkgrel=2
-pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. lalburst"
+pkgrel=3
+pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. ${_pkgname}"
arch=(any)
url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
license=('unknown')
@@ -15,12 +16,19 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=("http://software.ligo.org/lscsoft/source/lalsuite/${pkgname}-${pkgver}.tar.xz")
+source=("http://software.ligo.org/lscsoft/source/lalsuite/${_pkgname}-${pkgver}.tar.xz")
sha256sums=('2fc15ecd5cf195c2794234977f2c320efbcab2f294a03f8b5eda9ac7edbc93f1')
-package() {
- cd "$srcdir/${pkgname}-${pkgver}"
+build() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
sed -i 's/\-Werror//g' configure
- ./configure --prefix=$pkgdir/usr
+ ./configure --prefix=$pkgdir/usr CFLAGS=-O3
make -j
+}
+package() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
make install
}
+check() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
+ make -j check
+}