summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2017-10-08 09:16:16 +0100
committerWill Handley2017-10-08 09:16:16 +0100
commitce733f2b468e8ee0670b1f674f923b3b2c8a7cba (patch)
tree9809ce019db2459232528ad3e8e49c5f8dafafc2
downloadaur-ce733f2b468e8ee0670b1f674f923b3b2c8a7cba.tar.gz
First commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1df4686b251
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lalburst
+ pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. lalburst
+ pkgver = 1.4.4
+ pkgrel = 1
+ url = https://wiki.ligo.org/DASWG/LALSuiteInstall
+ arch = any
+ groups = lalsuite
+ license = unknown
+ depends = lalcore
+ options = !emptydirs
+ source = http://software.ligo.org/lscsoft/source/lalsuite/lalburst-1.4.4.tar.xz
+ sha256sums = 2fc15ecd5cf195c2794234977f2c320efbcab2f294a03f8b5eda9ac7edbc93f1
+
+pkgname = lalburst
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66274375b39d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=lalburst
+pkgver=1.4.4
+pkgrel=1
+pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. lalburst"
+arch=(any)
+url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
+license=('unknown')
+groups=('lalsuite')
+depends=('lalcore')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("http://software.ligo.org/lscsoft/source/lalsuite/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('2fc15ecd5cf195c2794234977f2c320efbcab2f294a03f8b5eda9ac7edbc93f1')
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ sed -i 's/\-Werror//g' configure
+ ./configure --prefix=$pkgdir/usr
+ make -j
+ make install
+}