summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2017-10-09 07:07:55 +0100
committerWill Handley2017-10-09 07:07:55 +0100
commit35bf0fcc50b474e539c6db0cfc0a916dd0e222cc (patch)
treea7cde4dd10d55772515f3b5c35bd057253db9876
parentb0a7085d074a8e28763ea21d4617025440e89116 (diff)
downloadaur-35bf0fcc50b474e539c6db0cfc0a916dd0e222cc.tar.gz
Added checks
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5e7a411268c..151fe24e0539 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lalcore
- pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. lalcore
+ pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. lal
pkgver = 6.18.0
- pkgrel = 4
+ pkgrel = 5
url = https://wiki.ligo.org/DASWG/LALSuiteInstall
arch = any
groups = lalsuite
diff --git a/PKGBUILD b/PKGBUILD
index 7dce4586f25d..a8d2df21aa4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
pkgname=lalcore
+_pkgname=lal
pkgver=6.18.0
-pkgrel=4
-pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. lalcore"
+pkgrel=5
+pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. ${_pkgname}"
arch=(any)
url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
license=('unknown')
@@ -15,12 +16,19 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=("http://software.ligo.org/lscsoft/source/lalsuite/lal-${pkgver}.tar.xz")
+source=("http://software.ligo.org/lscsoft/source/lalsuite/${_pkgname}-${pkgver}.tar.xz")
sha256sums=('464601c529f5607c251a54843e749bc9bd962055cc04ba21fdf6150e392a0ba2')
-package() {
- cd "$srcdir/lal-${pkgver}"
+build() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
sed -i 's/\-Werror//g' configure
- ./configure --prefix=$pkgdir/usr
+ ./configure --prefix=$pkgdir/usr CFLAGS=-O3
make -j
+}
+package() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
make install
}
+check() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
+ make -j check
+}