summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2017-10-08 09:14:00 +0100
committerWill Handley2017-10-08 09:14:50 +0100
commit823ec59ce506fafdec46e95b47c630a0289ce955 (patch)
treef1d19a7cb566a57776d25805d9da2ea80b865e87
downloadaur-823ec59ce506fafdec46e95b47c630a0289ce955.tar.gz
First commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e7f69060db6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lalcore
+ pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. lalcore
+ pkgver = 6.18.0
+ pkgrel = 1
+ url = https://wiki.ligo.org/DASWG/LALSuiteInstall
+ arch = any
+ groups = lalsuite
+ license = unknown
+ depends = gsl
+ options = !emptydirs
+ source = http://software.ligo.org/lscsoft/source/lalsuite/lalcore-6.18.0.tar.xz
+ sha256sums = 464601c529f5607c251a54843e749bc9bd962055cc04ba21fdf6150e392a0ba2
+
+pkgname = lalcore
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..384cbc04fa72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=lalcore
+pkgver=6.18.0
+pkgrel=1
+pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. lalcore"
+arch=(any)
+url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
+license=('unknown')
+groups=('lalsuite')
+depends=('gsl')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("http://software.ligo.org/lscsoft/source/lalsuite/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('464601c529f5607c251a54843e749bc9bd962055cc04ba21fdf6150e392a0ba2')
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ sed -i 's/\-Werror//g' configure
+ ./configure --prefix=$pkgdir/usr
+ make -j
+ make install
+}