summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2017-10-24 14:26:45 +0100
committerWill Handley2017-10-24 14:26:45 +0100
commitfab1ec144cea4ea83667787b6e7a0f6ee7c2685d (patch)
tree9c835ac94322a8c7701745cbf29e912dc22fe6f3
parente275db021bdc03049626b95a82e8aaf445550913 (diff)
downloadaur-fab1ec144cea4ea83667787b6e7a0f6ee7c2685d.tar.gz
Reorganised check functions
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea1e5f2c0014..1c87b382ace1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue Oct 24 13:26:45 UTC 2017
pkgbase = lalcore
pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. lal
pkgver = 6.18.0
- pkgrel = 6
+ pkgrel = 7
url = https://wiki.ligo.org/DASWG/LALSuiteInstall
arch = any
groups = lalsuite
diff --git a/PKGBUILD b/PKGBUILD
index 2d77d6bd684d..9125fe3061f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=lalcore
_pkgname=lal
pkgver=6.18.0
-pkgrel=6
+pkgrel=7
pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. ${_pkgname}"
arch=(any)
url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
@@ -18,17 +18,20 @@ options=(!emptydirs)
install=
source=("http://software.ligo.org/lscsoft/source/lalsuite/${_pkgname}-${pkgver}.tar.xz")
sha256sums=('464601c529f5607c251a54843e749bc9bd962055cc04ba21fdf6150e392a0ba2')
-build() {
+prepare() {
cd "$srcdir/${_pkgname}-${pkgver}"
sed -i 's/\-Werror//g' configure
+}
+build() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
./configure --prefix=$pkgdir/usr CFLAGS=-O3
make -j
}
+check() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
+ make -j check
+}
package() {
cd "$srcdir/${_pkgname}-${pkgver}"
make install
}
-#check() {
-# cd "$srcdir/${_pkgname}-${pkgver}"
-# make -j check
-#}