summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2017-10-08 09:16:35 +0100
committerWill Handley2017-10-08 09:16:35 +0100
commitb5ed3e02fa6dd308fd1165171954f1af0a448f0c (patch)
tree334e9eb46e2a6ce7f1d89d539d2f5782c116f0e5
downloadaur-b5ed3e02fa6dd308fd1165171954f1af0a448f0c.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9961e1991334
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lalframe
+ pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. lalframe
+ pkgver = 1.4.3
+ pkgrel = 1
+ url = https://wiki.ligo.org/DASWG/LALSuiteInstall
+ arch = any
+ groups = lalsuite
+ license = unknown
+ depends = lalcore
+ depends = libframe
+ options = !emptydirs
+ source = http://software.ligo.org/lscsoft/source/lalsuite/lalframe-1.4.3.tar.xz
+ sha256sums = cbb6ed39abb5a02d792523fc53208330cf8adf02bc4290cac635d42577acb5b1
+
+pkgname = lalframe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b11e9a07613b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=lalframe
+pkgver=1.4.3
+pkgrel=1
+pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. lalframe"
+arch=(any)
+url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
+license=('unknown')
+groups=('lalsuite')
+depends=('lalcore' 'libframe')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("http://software.ligo.org/lscsoft/source/lalsuite/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('cbb6ed39abb5a02d792523fc53208330cf8adf02bc4290cac635d42577acb5b1')
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ sed -i 's/\-Werror//g' configure
+ ./configure --prefix=$pkgdir/usr
+ make -j
+ make install
+}