summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2017-10-08 09:16:43 +0100
committerWill Handley2017-10-08 09:16:43 +0100
commitec9ad28af1f3697f5c5349bfc4037a3a1214fe20 (patch)
tree706c7af01dff090117770a55d8545a83d447a219
downloadaur-ec9ad28af1f3697f5c5349bfc4037a3a1214fe20.tar.gz
First commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD26
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38ad62d60228
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = lalinference
+ pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. lalinference
+ pkgver = 1.9.4
+ pkgrel = 1
+ url = https://wiki.ligo.org/DASWG/LALSuiteInstall
+ arch = any
+ groups = lalsuite
+ license = unknown
+ depends = lalcore
+ depends = lalmetaio
+ depends = hdf5
+ depends = lalframe
+ depends = lalsimulation
+ depends = lalinspiral
+ depends = lalpulsar
+ depends = lalburst
+ options = !emptydirs
+ source = http://software.ligo.org/lscsoft/source/lalsuite/lalinference-1.9.4.tar.xz
+ sha256sums = 73e9ee32507da91f176db790dc12b9a3d16a769ca3047af7c4fa279eaf915e31
+
+pkgname = lalinference
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f83f051b7ea6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=lalinference
+pkgver=1.9.4
+pkgrel=1
+pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. lalinference"
+arch=(any)
+url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
+license=('unknown')
+groups=('lalsuite')
+depends=('lalcore' 'lalmetaio' 'hdf5' 'lalframe' 'lalsimulation' 'lalinspiral' 'lalpulsar' 'lalburst')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("http://software.ligo.org/lscsoft/source/lalsuite/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('73e9ee32507da91f176db790dc12b9a3d16a769ca3047af7c4fa279eaf915e31')
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ sed -i 's/\-Werror//g' configure
+ ./configure --prefix=$pkgdir/usr
+ make -j
+ make install
+}