summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLambdAurora2018-06-23 10:37:09 +0200
committerLambdAurora2018-06-23 10:37:09 +0200
commit4c1aa565624d56b96254ce37ea7cc552a73817d6 (patch)
tree2a5546b319fedf31574657554b2803855254792e
downloadaur-4c1aa565624d56b96254ce37ea7cc552a73817d6.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD34
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5e5df4c2eab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lambdacommon
+ pkgdesc = A library written in C++ with common features.
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://github.com/AperLambda/lambdacommon
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = MIT
+ makedepends = cmake
+ conflicts = lambdacommon-git
+ source = https://github.com/AperLambda/lambdacommon/archive/v1.6.0.tar.gz
+ md5sums = SKIP
+
+pkgname = lambdacommon
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3d4d9a1d8f6b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+# Ignore file of lambdacommon package
+lambdacommon
+lambdacommon*.pkg.tar.xz
+pkg
+src
+v*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ae4f3edfc6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: LambdAurora <aurora42lambda@gmail.com>
+pkgname=lambdacommon
+pkgver=1.6.0
+pkgrel=1
+pkgdesc="A library written in C++ with common features."
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/AperLambda/lambdacommon"
+license=('MIT')
+makedepends=('cmake')
+conflicts=('lambdacommon-git')
+options=()
+install=
+source=("https://github.com/AperLambda/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake .\
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ cmake --build .
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ #make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ make DESTDIR="$pkgdir/" install
+}