summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Bruckner2015-06-08 03:06:46 +0200
committerMax Bruckner2015-06-08 12:55:32 +0200
commite4b0699046069b26e25b992a0c8f2cf843ebec0b (patch)
tree5af93128d7f16247b40842da8c092608089966e2
downloadaur-e4b0699046069b26e25b992a0c8f2cf843ebec0b.tar.gz
1.0.0-1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD19
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6703f6a2466d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lampe
+ pkgdesc = Interactive bash-script to control your Philips Hue lights.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/poinck/lampe
+ arch = any
+ license = custom
+ depends = curl
+ depends = bc
+ depends = zenity
+ source = git+https://github.com/poinck/lampe#tag=1.0.0
+ md5sums = SKIP
+
+pkgname = lampe
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..591121c0a3a3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+lampe/
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..069d336ffc28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Max Bruckner
+pkgname=lampe
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Interactive bash-script to control your Philips Hue lights."
+arch=("any")
+url="https://github.com/poinck/lampe"
+license=('custom')
+depends=( 'curl' 'bc' 'zenity' )
+source=( "git+https://github.com/poinck/${pkgname}#tag=$pkgver"
+)
+md5sums=( SKIP )
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+ install -d -m 755 "$pkgdir/usr/share/licenses/lampe"
+ install -m 644 LICENSE "$pkgdir/usr/share/licenses/lampe/CC0"
+}