summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2019-01-30 10:06:24 -0500
committerDavid Parrish2019-01-30 10:06:24 -0500
commit28f6a30e4b15b8e22ed0245525fa513a2162a3ff (patch)
treebb5ecde0b88da4ba8f248e3d91b10ee68d3aab93
downloadaur-28f6a30e4b15b8e22ed0245525fa513a2162a3ff.tar.gz
Initial commit for Lando PKGBUILD
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4813f9329a14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = lando
+ pkgdesc = A free, open source, cross-platform, local development environment and DevOps tool built on Docker container technology
+ pkgver = 3.0.0_rc.1
+ pkgrel = 1
+ url = https://docs.devwithlando.io
+ arch = x86_64
+ license = GPL
+ makedepends = npm
+ makedepends = yarn
+ makedepends = git
+ depends = docker
+ depends = docker-compose
+ optdepends = gcc-libs
+ provides = lando
+ conflicts = lando-git
+ options = !strip
+ source = lando::git+https://github.com/lando/lando.git#tag=v3.0.0-rc.1
+ sha256sums = SKIP
+
+pkgname = lando
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88a6379c61b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: David Parrish <daveparrish@tutanota.com>
+# Thank you inversechi and eschwartz
+# https://bbs.archlinux.org/viewtopic.php?id=235884
+
+pkgname=lando
+pkgver=3.0.0_rc.1
+_target_version=${pkgver//_/-}
+pkgrel=1
+pkgdesc="A free, open source, cross-platform, local development environment and DevOps tool built on Docker container technology"
+arch=('x86_64')
+url="https://docs.devwithlando.io"
+license=('GPL')
+depends=('docker' 'docker-compose')
+optdepends=('gcc-libs')
+makedepends=('npm' 'yarn' 'git')
+source=("${pkgname}::git+https://github.com/lando/lando.git#tag=v${_target_version}")
+sha256sums=('SKIP')
+conflicts=("lando-git")
+provides=("lando")
+
+# strip breaks executable
+options=(!strip)
+
+build() {
+ cd "${srcdir}/$pkgname" || exit
+
+ # https://github.com/lando/lando/issues/1309
+ npm install fs-extra@0.18.4
+ npm install
+
+ yarn pkg:cli
+}
+
+package() {
+ cd "${srcdir}/$pkgname" || exit
+ install -D -m 755 "dist/cli/lando-linux-x64-v${_target_version}" "${pkgdir}/usr/bin/lando"
+}