summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2018-11-23 20:31:34 -0500
committerDavid Parrish2018-11-23 20:31:34 -0500
commit42e9f539508f2660f88472db49070f8845ba23bd (patch)
treec67f4689c0f2e550e63c576e886ffb4a6712b5c2
downloadaur-42e9f539508f2660f88472db49070f8845ba23bd.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1872180ec65d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Nov 24 01:31:13 UTC 2018
+pkgbase = lando-git
+ pkgdesc = A free, open source, cross-platform, local development environment and DevOps tool built on Docker container technology
+ pkgver = 3.0.0.rc.1.r52.g3d2d7c23
+ pkgrel = 1
+ url = https://docs.devwithlando.io
+ arch = x86_64
+ license = GPL
+ makedepends = npm
+ makedepends = yarn
+ optdepends = docker
+ optdepends = docker-compose
+ options = !strip
+ source = lando-git::git+https://github.com/lando/lando.git
+ sha256sums = SKIP
+
+pkgname = lando-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e5b9912ca16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: David Parrish <daveparrish@tutanota.com>
+# Thank you inversechi and eschwartz
+# https://bbs.archlinux.org/viewtopic.php?id=235884
+
+pkgname=lando-git
+pkgver=3.0.0.rc.1.r52.g3d2d7c23
+_target_version="3.0.0-rc.1"
+pkgrel=1
+pkgdesc="A free, open source, cross-platform, local development environment and DevOps tool built on Docker container technology"
+arch=('x86_64')
+url="https://docs.devwithlando.io"
+license=('GPL')
+optdepends=('docker' 'docker-compose')
+makedepends=('npm' 'yarn')
+source=("${pkgname}::git+https://github.com/lando/lando.git")
+sha256sums=('SKIP')
+
+# strip breaks executable
+options=(!strip)
+
+pkgver() {
+ cd "$pkgname" || exit
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/$pkgname" || exit
+
+ # https://github.com/lando/lando/issues/1309
+ npm install fs-extra@0.18.4
+ npm install
+
+ yarn pkg:cli
+}
+
+package() {
+ cd "${srcdir}/$pkgname" || exit
+ install -D -m 755 "dist/cli/lando-linux-x64-v${_target_version}" "${pkgdir}/usr/bin/lando"
+}