summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2021-07-08 17:31:29 +1000
committerRod Kay2021-07-08 17:31:29 +1000
commit0b9e6bbc74ae37421eedc63faf1959cd91a0e7d2 (patch)
tree685ca16a5aa46635cf868ea280125c4195270acc
parent7f8a4e737451e4b76e71d8e1413a60ad80d684c8 (diff)
downloadaur-0b9e6bbc74ae37421eedc63faf1959cd91a0e7d2.tar.gz
Rid unused python dependencies.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26e6aec2fb84..0af00d88f4b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = langkit
- pkgdesc = Compiler for syntactic and semantic language analysis libraries
+ pkgdesc = Compiler for syntactic and semantic language analysis libraries.
pkgver = 20210518
pkgrel = 1
url = https://github.com/AdaCore/langkit/
@@ -9,17 +9,13 @@ pkgbase = langkit
license = custom
makedepends = gprbuild
makedepends = texlive-bin
+ makedepends = python-sphinx
+ makedepends = python-e3-core
+ makedepends = python-funcy
+ makedepends = python-mako
depends = gnatcoll-iconv
- depends = autopep8
- depends = python-psutil
- depends = python-sphinx
- depends = python-yaml
- depends = python-docutils
- depends = python-e3-core
- depends = python-funcy
- depends = python-mako
- depends = yapf
- source = langkit-20210518.tar.gz::https://community.download.adacore.com/v1/709e5ffa66fd8181655951e0ec8ed04e1d2977e2?filename=langkit-2021-20210518-19B8E-src.tar.gz&rand=398
+ depends = python
+ source = langkit-20210518.tar.gz::https://community.download.adacore.com/v1/709e5ffa66fd8181655951e0ec8ed04e1d2977e2?filename=langkit-2021-20210518-19B8E-src.tar.gz&rand=280
sha1sums = 709e5ffa66fd8181655951e0ec8ed04e1d2977e2
pkgname = langkit
diff --git a/PKGBUILD b/PKGBUILD
index 02a5165bc6aa..2518132419c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,26 @@
pkgname=langkit
pkgver=20210518
pkgrel=1
-pkgdesc='Compiler for syntactic and semantic language analysis libraries'
+pkgdesc='Compiler for syntactic and semantic language analysis libraries.'
url='https://github.com/AdaCore/langkit/'
arch=('i686' 'x86_64')
license=('GPL3' 'custom')
-depends=('gnatcoll-iconv' 'autopep8'
- 'python-psutil' 'python-sphinx' 'python-yaml' 'python-docutils'
- 'python-e3-core' 'python-funcy' 'python-mako' 'yapf')
-makedepends=('gprbuild' 'texlive-bin')
+depends=('gnatcoll-iconv' 'python')
+makedepends=('gprbuild' 'texlive-bin' 'python-sphinx' 'python-e3-core' 'python-funcy' 'python-mako')
_extract_dir="$pkgname-2021-$pkgver-19B8E-src"
-source=("$pkgname-$pkgver.tar.gz::https://community.download.adacore.com/v1/709e5ffa66fd8181655951e0ec8ed04e1d2977e2?filename=$_extract_dir.tar.gz&rand=398")
-sha1sums=('709e5ffa66fd8181655951e0ec8ed04e1d2977e2')
+_hash=709e5ffa66fd8181655951e0ec8ed04e1d2977e2
+
+source=("$pkgname-$pkgver.tar.gz::https://community.download.adacore.com/v1/$_hash?filename=$_extract_dir.tar.gz&rand=280")
+sha1sums=("$_hash")
build()
{
cd "$srcdir/$_extract_dir"
- # Make the Langkit Python package tree available for import
+ # Make the Langkit Python package tree available for import.
export PYTHONPATH="$srcdir/$_extract_dir"
# Build the Langkit_Support library, used by all Langkit-generated libraries.